Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Samba running on my home NAS (just a bare bones computer with an external HDD attached) in order to transfer files to/from a Windows machine. It's mostly working, I can browse the shares I have set up however I cannot write to them.

My hard drive is mounted on /media/HDD1. The relevant parts of my Samba config are below:

security = user

[Media]
   comment = Media Storage
   path = /media/HDD1
   create mask = 0775
   read only = no
   browsable = yes
   guest ok = yes

[Files]
   comment = File Storage
   path = /media/HDD1
   create mask = 0775
   read only = no
   browsable = yes
   guest ok = yes

When Samba is running, I can get to the shares from Windows by typing \\nas into Windows Explorer. However when I try to create a file/directory, or try to transfer one I get this error dialog:

http://i.stack.imgur.com/VvQH5.png

Obviously it's something to do with user permissions, however I don't know what. If I comment security = user in the config I get the same error. From what I know having read only set to no should enable me to read/write as I please.

Any help is greatly appreciated. :)

share|improve this question

migrated from serverfault.com Jul 7 '13 at 18:44

This question came from our site for professional system and network administrators.

    
Whitey, your question is about home-use equipment which is considered on topic on SuperUser. –  Deer Hunter Jul 7 '13 at 18:27

1 Answer 1

If you wanting to allowing everyone with full read/write permissions. Then make sure to set your config to:

browseable = yes

guest ok = no

create mask = 0777

Also, make sure that once you do that, you give the samba service user account access to those directories you specified. By running: chown and chmod on those directories. Once you get this to work then you can start reducing the permissions to 775 and specify user accounts.

share|improve this answer
    
s2000lover, please do not add signatures to your posts. –  Deer Hunter Jul 7 '13 at 18:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.