Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

At some point I've right clicked in Explorer to open a file in Notepad++ and the context menu is left floating around on my screen.

  • I've killed off both Explorer and Notepadd++ but the context menu remains.
  • I've tried to drop the window identification target from Process Explorer on to it but Process Explorer doesn't seem to see it.

Its really annoying because I don't want to reboot at the moment and its hovering right over everything! Does anyone know how to kill these things off without a reboot?

Thanks!

floating context menus

share|improve this question

marked as duplicate by gronostaj, Dave M, Mokubai, Shekhar, ncdownpat Oct 16 '13 at 20:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Is this only with this exact message? Is it only with notepad++? Does it happen even if you don't click that option? –  Chipperyman Jul 7 '13 at 23:38
    
It only happens very rarely but now that I think about it, it does seem to be Notepad++ specific. –  Luke Quinane Jul 7 '13 at 23:51

3 Answers 3

up vote 5 down vote accepted

Minimise all apps, then try the following:

  • Change your screen resolution and then change it back.

  • Run a full-screen app and then close it.

  • Use your monitor's auto-adjust option if it has one.

share|improve this answer
    
Nice thinking, changing the screen resolution fixed it! –  Luke Quinane Jul 8 '13 at 1:27

I press Ctrl + Shift + Esc to bring up Task manager, then find dwm.exe in the processes and kill the process. In a second, the explorer interface comes back and the dead item is gone.

share|improve this answer
    
Unfortunately this only seems to work 3/4 times. Then dwm stops appearing –  Ian Feb 20 '14 at 9:06

Floating CMs are annoying as hell and happen even in Xfce (GTK) here on my Debian desktop. However, the first technique I usually try used to work in Windows as well.

What I do is that I basically close them by Esc. However, that won't work if something else has the focus already, so now the tricky part is to get the focus on the menu without clicking an item in it:

  1. Click a disabled item or a separator

    This is obviously not possible when there's no such item, or even when there's only one item as we can see on your screenshot.

  2. Click and hold left ("the main") mouse button over the item, drag the mouse pointer off the item and release the button.

  3. Press Esc

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.