Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 8 PC (not laptop) that recently started having trouble connecting to wifi. When I click on the wireless icon, it does not list any networks to connect to. I tried a repair, but it just wants me to reset my router. Everything else in the house is able to connect to the wifi just fine. It is not a weak signal issue. The same problem happened earlier this week, and after I used the Windows 8 "refresh" feature, it began working again. I found this post that warned about multiple WAN Miniport adapters, but never gave a solution on how to fix that problem. When I originally started my troubleshooting, there were no WAN Miniport adapters showing up on my PC (and yes, I had show hidden devices on), but now (maybe after I connected to ethernet?) eight of them show up (IKEv2, IP, IPv6, l2TP, Network Monitor, PPOE, PPTP, SSTP). I tried to right click and uninstall them, but after saying OK to the "Confirm Device Uninstall" dialog, nothing seems to happen. Does anyone know how to solve this issue?

As a side note, I am running the Windows 8 Live Preview, so I guess it could be related to that somehow, but the wifi did work for a while after I upgraded.

share|improve this question

migrated from stackoverflow.com Jul 8 '13 at 7:25

This question came from our site for professional and enthusiast programmers.

add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.