Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to Citrix via Ubuntu 13.04. When I click on the application/VM button in my browser (url is .../Citrix/XenApp/site/default.aspx), button turns blue (before it was grey). Then, after 30 seconds, a window pops up:

Can't connect to '0.0.0.2 - Generaloffice'
Network is unreachable

Since I can connect to the web site, this seems kinda odd. How can I find out which connection the software is trying to make?

share|improve this question
    
Did you have any corporate Proxy Settings in within your Citrix Environment. If the setting for the Access Gateways are not set propably it gets the proxy settings from the corporate network which are not available for you in a public network. –  patricks Jul 8 '13 at 13:58
    
@patricks: I'm inside the corporate network. What is "Citrix Environment"? All I have is a Citrix plugin installed in my browser and a button in a web page that I can click. –  Aaron Digulla Jul 8 '13 at 15:31
    
You can debug the process with the following steps. First download the ICA File (right click on the application on the Citrix Website -> Save as...). Second step start the Citrix receiver via command line (don't know where ubuntu stores the client but you could try /opt/citrix/bin/wfica) with this options "/opt/citrix/bin/wfica -log $SAVEDFILE –  patricks Jul 9 '13 at 5:58
    
@patricks: Thanks the for tip; unfortunately, I failed to download the file. I just get a HTML file with some JavaScript that eventually contains document.location.replace('/Citrix/XenApp/site/launch.ica?... :-/ Is there another way to get this file? –  Aaron Digulla Jul 9 '13 at 9:07
1  
you have to setup your browser to download the ICA file instead of opening (or if you have the dialog -> just use "Save.."). –  patricks Jul 9 '13 at 11:14

1 Answer 1

up vote 0 down vote accepted

This happens because the ICAClient ignores the system's proxy settings. Instead of using the Web Browser/system's proxy settings, the client tries to connect first to the SSLProxyHost which is mentioned in the launch.ica file.

Try to configure the proxy settings manually.

Edit the file ~/.ICAClient/All_Regions.ini, look for [Network\Proxy]

Change the first two fields:

ProxyType=Script
ProxyAutoConfigURL=http://your.company.com/proxy.pac

I'm not sure what to put in there if you have the URL of a proxy server; maybe the documentation can help in this case.

Additional tipps:

If you can't download the ica file to start the client from the command line, disable the browser plugin and click on the VM button in the Citrix web site. The browser should then download and save the launch.ica file automatically.

If your client complains that it doesn't have a (root) certificate installed for SSL, you need to put more into /opt/Citrix/ICAClient/keystore/cacerts/. A simple source for those is Firefox; search your local copy for *.crt files like GeoTrust_Global_CA.crt. Copy or link those additional certificates to the cacerts folder and the client should be able to find and use them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.