Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a newbie to aws and postgresql I've launch an instance with quick wizard of linux ami 2013.03.01 It says that the instance include a repository access to postgresql - I thought that means that it's already installed on the machine, and since i could not locate it I decided to install postgresql on my own following this great guide in step 10:PostGIS installation when executing this command

./configure --with-pgconfig=/usr/local/pgsql/bin/pg_config --with-raster

i get the following warnings:

configure: WARNING: ImageMagick does not seem to be installed. Documentation cannot be built
configure: WARNING: dblatex is not installed so PDF documentation cannot be built
configure: WARNING: could not locate Docbook stylesheets required to build the documentation
configure: WARNING: could not locate CUnit required for unit tests

and the command ends with the following error:

configure: error: could not find geos-config within the current path. You may need to try re-running configure with a --with-geosconfig parameter.

i've tried this command

./configure --with-geosconfig=/usr/local/bin/geos-config

I get the same warnings as above and the following error configure: error: could not find pg_config within the current path. You may need to try re-running configure with a --with-pgconfig parameter. can some one help me what am I missing?

share|improve this question

2 Answers 2

You get some warnings about missing software. Why don't you install those?

yum install imagemagick

Etc for the other missing packages...

The configure problem, see http://postgis.17.x6.nabble.com/Why-can-t-PostGIS-configure-find-libgeos-c-td3552982.html and the reply

I might be outdated here, but the message seems clearly stating you're supposed to pass it a directory, not a file. Lame, but most likely that's your problem.

Try using: --with-geosconfig=/usr/local/bin

share|improve this answer
    
I tried the part with the directory, didn't work, I've installed the ImageMagic but I still get the other warnings about dblatex, Docbook and CUnit any ideas? –  liv a Jul 8 '13 at 19:06

You don't need to compile PostgreSQL and install it manually! Just use the existing packaged version:

sudo yum -y install postgresql postgresql-server postgresql-contrib
sudo service postgresql initdb
sudo /sbin/chkconfig --levels 235 postgresql on
sudo service postgresql start

... per the first Google hit for "amazon linux install postgresql".

That said, Amazon Linux's PostgreSQL packaging is bad bordering on incompetent, and it should be avoided in favour of a distro that has properly maintained PostgreSQL packages like Ubuntu, Debian, or Fedora/RHEL.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.