Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Gigabyte Avia K8100 keyboard and I am running in to some problems with certain keys.

The down arrow key, left ALT key and '[]' keys are not working any more. I believe this may be a hardware issue.

Are there any known fixes?

share|improve this question
    
The keys were working before, right ? Maybe you changed accidentally the language of the keyboard, have you checked that ? –  Devid Jul 8 '13 at 14:42
    
Yes, they were working before. I haven't changed any settings since I bought it a few months back. The down arrow key seems to be working now as well as the [] keys. However, left ALT still ceases to work. Could it be some debris under the keys? –  Liam Potter Jul 8 '13 at 18:35
    
Because it is only 1 month old you could also contact the service. If something is broken it will be repaired for free –  Devid Jul 8 '13 at 20:16
    
Keyboards do have a limited life span (I've gone through a few, recently replacing the keyboard both at home and at work but for different failure reasons) but a few months is awfully short. Contact the manufacturer, it should be covered by warranty and they should be able to instruct you on how to clean your particular model keyboard safely. If not, your best bet is probably to get a new keyboard. –  Michael Kjörling Jul 11 '13 at 9:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.