Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use Solver in 64-bit Excel 2010.

When I run Solver, it opens the solver window, states that it has results and then popups the following error message:

Run-time error '53'

File not found: Solver32.dll

So, it would seem that the Solver32.dll cannot be loaded. It is however, available in the Solver Directory - i.e. C:\Program Files\Microsoft Office\Office14\Library\SOLVER contains SOLVER.XLAM and SOLVER32.dll

What have I tried so far...?

  • did a full Office 2010 Repair

  • this Microsoft forum suggested copying the Solver32.dll to C:\Windows\SysWOW64 (which is where Windows 7 stores it's 32-bit dlls).

  • this forum suggested installing the Solver add-in (.xlam and .dll) to ..\AppData..\Microsoft\AddIns

I have tried both of these and neither of them worked...

share|improve this question
    
Are you running 64bit excel on a 64bit OS? Are you running solver from the ribbon or in vba? Do you have any other add-ins enabled? –  Raystafarian Jul 13 '13 at 11:15
    
Yes, I am using a 64-bit OS. I am running solver from menus. Yes, I have other add-ins enabled... but I'd be mightily surprised if that was an issue. –  amaidment Jul 15 '13 at 10:29
    
Does this still occur if you disable all the other add-ins? –  Raystafarian Jul 18 '13 at 21:13

1 Answer 1

I just ran into this problem as well, though I'm using Excel 2013.

Here's what I did to solve the problem:

  1. Go to File > Options > Add-Ins > Manage Add-Ins Go Button (at the bottom)
  2. Uncheck Solver add in (in other words, remove it)
  3. Completely close all Excel spreadsheets and programs
  4. Open Excel
  5. Follow step one again
  6. Add solver back to Excel

For some reason this worked for me. It's important to completely close Excel (as noted in step 3): when I did this without closing excel, it didn't work.

Hopefully this helps someone in the future, since I doubt the original user still has this problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.