Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to disable the Omnibar in Chrome from searching within a specific site rather than Google when I start my search with that site's name?

For example, when I'm trying to search for information about Last.fm, I begin my search with "last.fm", and as soon as I press Space, it defaults to searching within Last.fm. This also happens with some .com sites, even if I leave off the .com part (such as Amazon), but not others (such as Reddit).

I'm fine with the normal behavior of pressing Tab to search within the site, but I just don't want it done automatically, so is there a way to turn this off?

share|improve this question

4 Answers 4

up vote 4 down vote accepted

When you want to indicate to the Omnibar that you want to search for something, start your query with a ?. Then it will always perform a search through your selected search engine.

For example:

?last.fm something
share|improve this answer
    
This seems to be the simplest solution, thanks! –  trevwilson Jul 15 '13 at 13:17

Open the chrome settings and go scroll down the page to find to the Manage search engines... Google documentation or go to the URL chrome://settings/searchEngines.

In the dialog you will find all installed search providers. The second column is a keyword that will trigger searches for that provider. For example if you have the keyword amazon want to search amazon you type amazon + tab and enter your search.

You can choose to edit the keyword or to delete the search provider from this page depending on your preference.

If you want to force a google search and google is your default search provider you can press ctrl+k to start searching alternatively start your query by writing ? this will ignore your keywords.

share|improve this answer

I don't think you will be able to do exactly that.Following are the alternative ways you can do that.

  1. You could go into chrome settings - Manage search engines and remove Amazon from the list, if Chrome adds it again you could change the keyword to something obscure. (this of course will not allow you to use the tab search feature.

  2. add the search key phrase first and the website name

  3. type in google first and press tab to search into google

  4. You could also clear your browser history so that chrome doesnot autopopulate the website in the address bar and hence not hit the search keyword.

But as I mentioned these are all workarounds

share|improve this answer

What's happening here is that chrome automatically adds search engines that it finds, and generates some keywords along with them, which is what's happening right now. To subvert this, you can remove the keywords or the search engines entirely.

  1. Go to the settings, because that's where it's at!
  2. Click the button called Manage search engines... under the Search section.
  3. Now, a dialog should open. The leftmost fields on each row are the names, the middle ones are the keywords that work by you starting your search with that keyword, and the rightmost field are the URLs where the browser sends the query to. Here, if you don't want to use keywords, you can just erase the keyword fields.
  4. ???
  5. You can now search hassle-free!

Or umm, you can just start your search with a space, before the keyword, like:

 last.fm thatsongIheardatthatplaceoverthere

(notice the space before last.fm)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.