Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some days ago, I got a problem with my Micro SD. The problem is this:
When I connect my Micro SD to PC, and when I went to its drive, i can not see anythings there. Just there is a Shortcut with the below Target :

C:\Windows\system32\rundll32.exe _WYMGAZLE.init,krnl pubrxdiotaqvchnszpuf intkps 

When i goes to this target,I can see and use my files! and there is a System Folder in my MicroSD Called " " (Just a Character) and when i goes to this folder i can use my files to. Also I fully Formatted my MicroSD but still this problem exist !

My Question:
How can I Fix my MicroSD "Shortcut" problem?

share|improve this question
    
You still see a shortcut on the card even after formatting it? Try deleting all partitions via Disk Management (or via diskpart / select disk / clean), then create a new one, format and see if the problem persists. –  Karan Jul 8 '13 at 21:45
    
How can i use "diskpart" ? i tried Disk Management and when i tried to delete my Micro SD Partition, i see it was not Available to delete it. –  Amirreza Nasiri Jul 8 '13 at 23:21
    
From an elevated/admin cmd prompt: 1. diskpart 2. list disk 3. select disk <number> 4. clean. If that doesn't work use a Linux system or LiveCD/USB and wipe the drive using GParted. As suggested below also be sure to scan your PC for malware. –  Karan Jul 8 '13 at 23:30
    
@Karan : I cleaned it, and then made a new volume (simple), but it didn't fixed! still I have shortcut problem. –  Amirreza Nasiri Jul 9 '13 at 0:29
    
Also you could try Process Monitor, which performs pretty detailed monitoring (so you will probaly need to play with filtering rules for a while) –  Alois Mahdal Jul 9 '13 at 0:38

1 Answer 1

I'd suspect a Trojan or a rootkit could be placing the files back.

Look for an anti-virus Live CD (at teast two major companies provide them for free) and scan your system when booted from it, including the MicroSD card.

share|improve this answer
    
No, there is no any Trojan or Rootkit. –  Amirreza Nasiri Jul 8 '13 at 23:16
    
@AmirrezaNasiri Impressive, indeed. Do I assume correctly that you have already performad the scan? I thought that point in rootkits is that they are invisible for the system being compromised. Obviously 4 years in AV testing is not enough to grow a super-power. ;) –  Alois Mahdal Jul 8 '13 at 23:36
    
I Scanned my PC Using 3 kind of different anti-viruses. [Kasper,Bitdef,Avast]. I was sure that there is no any malwares in my computer because i never connect it (my another computer) to Internet, any USB and etc, i have 2 kind of firewall (windows-firewall) and one Kaspersky (Pro edition) and some other security softwares. so i'm sure there is no malwares in it! But i don't know why this Happened! I do anythings to fix it but i could't :( !! –  Amirreza Nasiri Jul 9 '13 at 0:22
    
Regarding using different AVs/Firewalls on the same machine, don't expect that it will increase security. In fact, it's rather the opposite, since the different components can collide in each other (not every AV provider is willing to test their product with competition, and if hey do, they can only care if their one works). Also I'm confused about the part with not connecting any USB: You do connect the card, do you? –  Alois Mahdal Jul 9 '13 at 0:29
    
I Just connect my MicroSD (i had same problem in other machines before connecting it to this machine!) Also i fully scanned it (inclouding my MicroSD and all of my data). but i have same problem ! –  Amirreza Nasiri Jul 9 '13 at 0:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.