Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Originally posted on http://stackoverflow.com/questions/17527293/cuda-5-5-on-ubuntu-12-04-not-running-on-nvidia-gf-630m

I have a laptop with an Nvidia GeForce 630M graphics card running on Ubuntu 12.04.

Running lspci | grep -i nvidia I get the following line

01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev al)

and according to https://developer.nvidia.com/cuda-gpus my graphics card is compatible.

After compiling the samples and running the deviceQuery I get the following output:

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 10
-> invalid device ordinal
Result = FAIL

I read online that this error is because my graphics card is not compatible.

If I run jockey-gtk to check the Additional Drivers I get the following list

nvidia_current (Enabled)
NVIDIA binary Xorg driver, kernel module and VDPAU library (Not Enabled)
Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Not Enabled)

When I select tne nvidia_current I get at the bottom a green button and This driver is activated but not currently in use

I downloaded CUDA 5.5 as a .deb package and followed the instructions posted on the website

EDIT

After running nvidia-smi -a as Robert mentioned in the comment I get the following output

NVIDIA: could not open the device file /dev/nvidia0 (Input/output error)
Unable to determine the device handle for GPU 0000:01:00.0: Unknown Error

How can I possibly fix it?

share|improve this question

1 Answer 1

I have the same problem with you. This is what I've done to make it work properly:

  1. Create new module blacklist

    # touch /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
    
  2. Now blacklist nouveau

    # echo -e "blacklist nouveau\noptions nouveau modeset=0" > /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
    
  3. Restart your PC / Laptop

  4. If the problem persist, reinstall your NVIDIA driver, make sure you have downloaded the latest NVIDIA driver from here‎. Save it anywhere and change its permission to executable with this command

    # chmod +x NVIDIA-Linux*
    
  5. If you have problems with building new NVIDIA module, install kernel header with this command

    # apt-get update; apt-get install linux-headers-$(uname -r)
    
  6. Now reinstall your NVIDIA using this command

    # ./NVIDIA-Linux{your version}
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.