Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently trying to run a file located at C:\Chocolatey\lib\ScriptCs.0.5.1\tools\scriptcs\scriptcs.exe

Originally I tried popping up a CMD and running the command scripts as it should already be on my path. Problem is I get a popup error saying:

C:\Documents and Settings\ZSmith\Application Data\scriptcs\scriptcs.exe 
is not a valid Win32 application

and it outputs "Access Denied" to the CMD. After this I ran

find -name 'scriptcs.exe'

just to check where it installed to. The default install directory is C:\Chocolatey\lib\ScriptCs.0.5.1\tools\scriptcs\scriptcs.exe as I've said. Attempting to run it from there produces the same error.

Perhaps I'm failing to understand the administrative principals of Windows XP and there's a conflict there but I believe I have complete admin control of my computer (barring access to the admin account as this is a work computer). I did recently install Cygwin. I'd not tried running scriptcs before that on its own. Cygwin could possibly be causing a conflict but I doubt it.

share|improve this question
What script are you running? it appears that a step in the script you are running is attempting to run %appdata%\scriptcs\scriptcs.exe. – Scott Chamberlain Jul 9 '13 at 14:48
The error's completely unrelated. I'm closing the question. Turns out there's no x86 compatibility for ScriptCS. There's no documentation on it. Had to submit an issue on Github to get an answer. – DanteTheEgregore Jul 9 '13 at 14:53
up vote 1 down vote accepted

As mentioned here, you need to build a 32-bit version from source.

share|improve this answer
Thank you but I already mentioned that in the comments. That ticket's basically inactive. See the ticket I submitted here: – DanteTheEgregore Jul 9 '13 at 18:02
Your ticket was marked as a duplicate of that one. The ScriptCS sources are available, and there's a build.cmd in there. If you have Visual Studio installed I guess you could build a 32-bit EXE yourself, which is what is suggested as the solution. Otherwise look around for someone who's already done so and shared the pre-built executable. – Karan Jul 9 '13 at 18:13

More generally, I was trying to use an application with this problem; it turns out that the build had been reconfigured to no longer support Windows XP. Getting an older build which still had the XP compatibility fixed it for me.

So, getting a 32-bit build is not a sufficient fix if the build is not also configured to use the _xp toolset.

The error is kind of insidious because the "Access Denied" error message is somewhat misleading and common google hits on this error message suggest the download was corrupted or something.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .