Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Samba server configured running on an OpenWRT router. It makes several shares available accessible to anyone (as guests), some even allow writing. This all works fine.

Now, I'd like to add a writeable share accessible only by a single named user with a password. I have added a system user, and an appropriate share as per the OpenWRT manual on Samba. I have also set a password with smbpassword.

Then I tested this very share with the same password using my Ubuntu's file manager (Files 3.6.3). It was mounted correctly, and I had read/write access as expected.

Windows 7, however, when trying to access the share, throws an authorization error. I tried logging in as different users and inputting those known credentials but it returns the unknown user or incorrect password* error every time.

I'm pretty sure the password is correct unless there is some weird encoding issue. They're generated with pwgen -s so no weird stuff.

I tried rebooting, leaving the network work group, I changed the password to a shorter one (7 characters), restarted samba before connection attempts... to no avail. It consistently works for the Ubuntu machine and consistently doesn't for Windows 7.

What's the problem here? Or how could I at least get some detailed information?

Samba logs on the server are empty

# ls /var/log/log.*
/var/log/log.nmbd  /var/log/log.smbd
# cat /var/log/log.*

Other info:

# smbd --version
Version 3.6.5
share|improve this question

migrated from Jul 9 '13 at 18:21

This question came from our site for system and network administrators.

Do you have password encryption enabled on Samba? From reading this thread also make sure that 'server signing' is at least auto. 'always' is acceptable too. – Fred Clausen Jul 9 '13 at 15:48
have a look to… This enabeld me to connect from Win7 to OpenWrt samba package 3.0.24-8 – user268803 Nov 1 '13 at 20:13
Have you tried putting the OpenWRT's hostname prior to the username in the format hostname\user (e.g. openwrt\admin) - if the computer isn't on a domain and you try to authenticate with an account on different host then you need to provide the hostname of where the account is to use. – Big Chris Jun 23 at 9:34

Verify that you have NTLM v1 enabled as a fall back authentication:


Key is LmCompatibityLevel Value should be 1

If it is a different DWORD value, fix it.

If that key is not there at all, you can add it or run this from a command prompt with admin access:

reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa /v LmCompatibilityLevel /t REG_DWORD /d 00000001 /f
share|improve this answer
The key was not present but adding it (and rebooting) didn't help. Thanks anyway. – Damn Terminal Jul 16 '13 at 23:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .