Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have consistently been having a problem with my computer overheating due to the process QuickLookSatellite-general using 100+ CPU use. (Please see images attached.)

enter image description here

enter image description here

On googling I found this process is associated with Draftsight, a CAD program. I do not and have never had this program installed.

Restarting does not even fix this problem. I am also worried about damaging my Macbook at such high CPU temperatures.

Any assistance is appreciated.

share|improve this question
up vote 5 down vote accepted

Troubleshooting steps:

  • See if there are any relevant log messages in Console.app or /var/log/system.log.
  • Use qlmanage -r to reset Quick Look client's generator cache.
  • Run sudo opensnoop -n QuickLookSatellite-general to see if the process hangs after accessing some specific files. Or select QuickLookSatellite-general in Activity Monitor, press command-I, and see the Open Files and Ports tab.
  • Temporarily delete Movie.qlgenerator, Audio.qlgenerator, or other qlgenerator bundles in /System/Library/QuickLook, and run qlmanage -r.
  • Temporarily remove applications shown by qlmanage -p | grep /Applications/.
  • Disable quicklookd with launchctl unload /System/Library/LaunchAgents/com.apple.quicklook.*. The plists are loaded again after you log out and back in.

If nothing else works, you could try doing an upgrade install of OS X from the recovery partition.

share|improve this answer
    
this is awesome. Great to know for other applications as well. Thank you! – andrsnn Jul 9 '13 at 21:50
    
It looks like resetting the clients generator cache seemed to solve it, but if it acts up again I will try some of your other steps. – andrsnn Jul 9 '13 at 22:23
    
Just to add to this I find other programs also behaving like above. Firefox and bitcoin client behave the same way. – andrsnn Jul 10 '13 at 18:00

What I also found helpful was to turn on QuickLook debugging so I could see exactly what files were being processed. You can do that with this in the terminal. More info in the Mac Developer Library.

defaults write -g QLEnableLogging YES

You can also adjust the debugging level using qlmanage -d debuglevel. Run qlmanage -h for more info.

In my particular case it was QuickSilver causing the issue, which I fixed by disabling image previews using this command in the terminal. My thread on that is here.

defaults write com.blacktree.quicksilver "QSLoadImagePreviews" NO

Also see this similar AskDifferent question.

share|improve this answer

For me, deleting ~/Library/Application Support/Quick Look/cloudthumbnails.db* seems to have done the job.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .