Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

VMware Workstation 7 on Win7-64 (Home Premium).

I have confirmed this on any guest running on this machine (from winxp to debian).

I am using a bridged network connection for my guests (Automatic on VMnet0). All of the network configuration is done with DHCP (including on the host).


What I can not do:

  • Ping my host machine from inside any VM. (either shows me "Destination Host Unreachable" or will just timeout)

What I CAN do right after power up, with no problems at all.

  • I can connect to the internet from inside the VM
  • I can ping my router from inside the VM
  • I can ping other machines on my network from inside the VM
  • Other machines can ping the VM
  • Other machines can ping the host
  • My host machine can ping the VM (this one is important. read further)


So I have my router assigned as, and the router provides the DHCP service (and it seems to be doing so successfully).

There are no IP conflicts on the network that I am aware of. All Gateways and Subnet masks are appropriate and matching.

My entire workshop is on one single subnet, with one single DHCP server and gateway.

There is one method in which I can ping successfully, but it requires an active connection initiated from the host (I start pinging from host to VM). During the period of the active connection, I can successfully ping from VM to host, using explicit IP address. As soon as the host connection is closed, the VM ping starts hanging with the same old messages.

My Thoughts

This really feels like a firewall problem, but I have turned off all firewalls on host and VM, powered down the network, powered back up, and the problem still persists. And if it was firewall, why would only the IP address associated with bridged VM networks be blocked.

I feel as though my host operating system (Win7) is somehow configured incorrectly, or, VMware Workstation is configured incorrectly from the host side. Although I have done my best to put everything in default, I feel like I am missing something silly.

share|improve this question
Did you resolve this? I'm having the same problem… – mowwwalker Jul 18 '13 at 8:35
At the risk of sounding like a jerk - and only because it just worked for me - "Have you tried turning it off and on again?" The host PC, I mean. – marklark Apr 6 at 20:45
There seems to be more than one reasonable answer if you read down below, as it also seems there may be a few different causes that can create this problem. The best quick answer, is that somehow your host network adapter (the one you are bridging) is incorrectly set up or has other software interfering with it. Below you should find directions on where you might start looking. – user2097818 Oct 18 at 23:00

4 Answers 4

up vote 9 down vote accepted

I had same problem, couldn't ping to <-> from host and guest. Other networking was fine. I unchecked the DNE LightWeight Filter I had installed and it fixed it. Thanks to Walkerneo's comment. My DNE filter came from Citrix.

  1. Network and sharing center
  2. Select your adapter that has Internet
  3. Click properties button from the Connection Status Window
  4. Uncheck DNE LightWeight Filter in the Adapter's proerties
  5. Click OK and wait for your adapter to reset itsetf
share|improve this answer
I was pulling my hair out at this, and it worked perfect! Thank you! – Kyle Lowry Nov 8 '13 at 7:11
Thanks a bunch for the answer. Fixed it for me. – Safado Jun 24 '14 at 15:50
Holy smokes. I had forgotten I have DNE installed (installed it for some random Cisco VPN client fix). Thanks! – freb Sep 27 '14 at 22:51
I have changed my hostOS since the original post, no longer have this problem, and therefore can no longer verify the actual problem/solution myself. This was voted the most popular so I am going to mark this as the accepted answer. Although I did not use Citrix, I can recall a number of programs I installed that may have placed a filter on my network adapter without me realizing it was there, and could have been a very likely cause in my own case. – user2097818 Apr 7 at 13:06

You need to enable the VMware bridge protocol on the host.

Go to Network and Sharing Center. On the right side there will be a list of connections (Access Type: Connections), select the VMware Network Adapter. Open Properties, check the VMware Bridge Protocol box and exit the screen.

share|improve this answer
Am using bridged mode and my RHEL is configures with public ip. and am not ableto ping from outside – Vishwanath gowda k Nov 6 '14 at 6:20

So far, my conclusion is that the bridging mechanism is somehow causing the problem. I also feel that this may be version/OS specific, as I do not recall this problem in the past (although, I may be wrong).

When using a second NIC on my host machine, my VM is able to ping that NIC, but not the NIC that is providing the bridged connection. (each NIC has a different IP address)


There was definitely something altering the bridged connection, although I have re-installed the operating system recently, so I cannot conclusively say what the the issue or solution was. Problem never re-occurred (although I was much more selective about the software I installed, which might suggest the now accepted answer)

share|improve this answer
Hello, I just solved this problem for myself! It was because of the driver SonicWall installs. I'm curious to know if this (or something similar) solves the problem for you as well. Try right-clicking your network adapter, going to properties, and seeing if anything out of the norm shows up. Disabling 'DNE LightWeight Filter' worked for me. Good luck! – mowwwalker Jul 19 '13 at 4:24
@Walkerneo You should post this as a proper answer, as your comment helped at least two other people who posted answers to confirm it. – slhck Oct 4 '13 at 9:46

I had the same problem, what really solved my issue is enabling Adhoc support 802.11n for the active network adapter.

What you have to do is,

  1. Go to My Computer properties
  2. Under Network Adapters, right-click on your network adapter and go to Properties
  3. Go to Advanced tab.
  4. Set the value of Adhoc support 802.11n to Enable.
share|improve this answer

protected by Community Dec 29 '13 at 5:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.