Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I change the set of languages presented in GNOME 3 to match the set of languages described by the system locales in /etc/locale.gen?

“System Settings” → “Region and Language” → “Language” lists a set of languages. But that set of languages does not match the /etc/locale.gen (created by dpkg-reconfigure locales); it has several additional languages, including one “Unspecified” with some ANSI code.

There should be no languages in that list that are not existing system locales, and all of the existing system locales should be in that list. I don't know why they'd differ.

Selecting one of the languages that don't have a corresponding system locale causes errors that the locale is not found, of course.

I don't want any languages to appear as options if they haven't got locales generated on this machine, and I want all the system locales supported by GNOME to appear in that list. How can I tell GNOME 3 to conform to the available operating system locales?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.