Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have internet signal in gray cord in below snapshoot. I can have wifi internet connection when plugging in the gray cord to port 1,2,3,4 and NOT to the internet port as shown in the snapshoot.

Currently I use blue cord to share internet to my PC. It works with one cord in any of the port 1,2, and 4. But when I plug in ANOTHER cord to use on the 2nd PC, the LAN connection show in that PC reads "Unidentified Network - No internet access"

What I am doing wrong? How can I share LAN internet for 2 PCs?

enter image description here

My wireless modem is as below snapshoots

enter image description here

enter image description here

Here is the modem that provide the internet signal for gray cord

enter image description here

enter image description here

enter image description here

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Your gray cable is plugged into your ISP router and that is where your "Internet" is coming from. Some ISP routers like the Motorola surfboard only hand out 1 IP address. That one address is getting assigned to the first pc on your network since you are using the other router as a switch. When you plug in a second cable there is no internet access because your first PC already has the one address your ISP router is willing to give out. To resolve this

  1. Plug your gray cable from your ISP router/modem into the internet port on your Dlink modem

  2. The deault IP for your model Dlink is 192.168.0.1 Open an internet browser and put in that IP address. The default username is "admin" and default password is blank.

  3. Setup your Dlink router. Link to some useful settings to use.

  4. Plug your blue cable and up to three other Ethernet cables into the remaining Lan ports. As long as you setup DHCP on your Dlink you will be able to connect multiple PC's to your internet.

share|improve this answer
    
Awesome. This is what I'm looking for! Thanks a lot! –  Nam G VU Jul 12 '13 at 2:46
    
Dear Ryan, I tried to plug the gray cord into internet port and trying to access 192.168.0.1 and 192.168.1.1; neither of them open the admin page for the modem. I have update my question to provide more about the gray cord. Please help –  Nam G VU Jul 12 '13 at 4:11
1  
You can do a 30/30/30 reset on your Dlink. 1. While the Dlink is plugged in, press and hold the reset button for 30 secs. 2. While still holding down the reset button, unplug the Dlink and keep holding the reset button for 30more secs. 3.While still holding down the reset button, plug the Dlink back in, continue to hold the reset button for additional 30 secs. This will factory reset your Dlink. –  Ryan E Jul 12 '13 at 17:03
    
Also check your IP address. Make sure you are not still using the address from the ISP modem. Make sure you are getting an address in the 192.169.x.x range. –  Ryan E Jul 12 '13 at 17:10
    
Please check whether it is 192.169.x.x or 192.168.x.x? And the IP address to check is the modem IP or the IP I get on my PC after connected with the blue cord? –  Nam G VU Jul 12 '13 at 17:36
show 3 more comments

Why are you not plugging in your Internet-facing cable into the Internet port?

Any cable modem or DSL router I've ever ran into will NOT work if you try to share it using a switch. The four ports on your router are actually an integrated switch.

The reason being is that the cable modem or DSL router will only continue talking with the first device it finds on its Ethernet port.

You'll likely run into a similar situation if you connect a computer directly to your cable modem or DSL router, and then later try to move the connection to another computer. It probably won't work until you reboot the cable modem or DSL router.

To properly share your Internet amongst multiple devices, connect it to the Internet port on your router, and then log into the configuration page of your router (the instructions should have been included) and perform the necessary set up.

share|improve this answer
    
Thanking for your helpful explanation! I appreciate that very much! –  Nam G VU Jul 12 '13 at 2:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.