Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have downloaded two versions of Linux kernel 3.9.9 and 3.10 from When I am trying to untar this file I am getting this error

Lzma library error: Corrupted input data

. I am not getting what is going wrong. I am sure that my downloaded file is not corrupted because I have downloaded this file for 3 times and in all 3 instances I get the same error. Can anyone suggest me what should I do to untar this file? I am using Ubuntu 13.04. Thank you.

share|improve this question
What are the URLs and the commands you executed? – pilona Jul 10 '13 at 17:59
this is the link where from I downloaded the file – Still A Learner Jul 10 '13 at 18:02
and for untaring I just used Archive Manager that comes pre-installed in Ubuntu – Still A Learner Jul 10 '13 at 18:03
Works for me. Not on Ubuntu. Just using tar 'directly'. – pilona Jul 10 '13 at 18:38
wget -O- | tar -xJ – pilona Jul 10 '13 at 18:39

Open a terminal and do this:

tar xvf linux-3.10.tar.xz   
share|improve this answer
I tried out this earlier but it does not work. It gives following error: xz: (stdin): Compressed data is corrupt tar: Unexpected EOF in archive tar: Unexpected EOF in archive tar: Error is not recoverable: exiting now – Still A Learner Jul 10 '13 at 23:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.