Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have downloaded two versions of Linux kernel 3.9.9 and 3.10 from kernel.org. When I am trying to untar this file I am getting this error

Lzma library error: Corrupted input data

. I am not getting what is going wrong. I am sure that my downloaded file is not corrupted because I have downloaded this file for 3 times and in all 3 instances I get the same error. Can anyone suggest me what should I do to untar this file? I am using Ubuntu 13.04. Thank you.

share|improve this question
1  
What are the URLs and the commands you executed? –  pilona Jul 10 '13 at 17:59
    
this is the link where from I downloaded the file kernel.org/pub/linux/kernel/v3.x/linux-3.10.tar.xz –  Still A Learner Jul 10 '13 at 18:02
    
and for untaring I just used Archive Manager that comes pre-installed in Ubuntu –  Still A Learner Jul 10 '13 at 18:03
    
Works for me. Not on Ubuntu. Just using tar 'directly'. –  pilona Jul 10 '13 at 18:38
    
wget -O- https://www.kernel.org/pub/linux/kernel/v3.x/linux-3.10.tar.xz | tar -xJ –  pilona Jul 10 '13 at 18:39
show 1 more comment

1 Answer

Open a terminal and do this:

tar xvf linux-3.10.tar.xz   
share|improve this answer
    
I tried out this earlier but it does not work. It gives following error: xz: (stdin): Compressed data is corrupt tar: Unexpected EOF in archive tar: Unexpected EOF in archive tar: Error is not recoverable: exiting now –  Still A Learner Jul 10 '13 at 23:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.