Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Debian Linux to one of of my storage drives alongside Windows 7 (on a different drive) and for some reason when I start up my computer I still boot right into Windows instead of GRUB. I assume this is because it was not installed to my MBR correctly for some reason. Are there anyways to fix this so it does boot to grub or am I going to have to reinstall Debian to get it to work?

share|improve this question

3 Answers 3

If you have install debian on another physical drive GRUB have probably been install on this drive, but your motherboard is probably set to boot on the hdd containing windows.

You can boot on a live cd and install grub on the hdd containing windows 7. After, if your windows 7 installation is not recognized you'll be able to edit your grub configuration and add a windows entry.

Here is the debian grub installation tutorial

The other solution is to set your motherboard to boot on the hdd where Debian is install. Like the first solution, if Windows 7 is not recognized, you juste have to add an entry to the grub configuration.

share|improve this answer
    
The Live CD option sounds good. What are some good ones? –  Seth Wilson Jul 11 '13 at 2:32
    
Debian live live.debian.net is a good choice. –  nodiscc Jul 15 '13 at 20:59

You say that you had to install it on another drive? So you could try going into the BIOS and changing the boot priorities from there. Since it sees the windows drive first, it boots of that one.

NOTE: This will only work if you installed it on another hard drive and not just a partition.

share|improve this answer

You can get a "live-cd" from many linux distributions. I usually use xubuntu as it boots on lots of hardware. Burn that to a cd (usualy a "write image" option). That will "unpack" the .iso file onto the disk. When finished, boot the cd (you may have to set your BIOS to boot to the cd drive first).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.