Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like Microsoft Natural 4000 keyboard but I hate "FLOCK" key. It seems sometimes I push it by accident and then F1-F12 keys stop working.

For Example in Windows Explorer I try to rename file pressing "F2" but instead of that I involve "Undo" action. So instead of renaming files I have created previously just disappear! It's very inconvenient! I never use "Function keys" so can I somehow just have FLOCK enabled?

share|improve this question

migrated from serverfault.com Jul 11 '13 at 14:03

This question came from our site for professional system and network administrators.

    
Possible dupe: superuser.com/questions/618467/… –  ernie Jul 11 '13 at 16:04

2 Answers 2

up vote 2 down vote accepted

I don't think you can disable the key, however, you could just replace the function on the key with a macro like so.

  1. Open Microsoft Mouse and Keyboard Center.

  2. Select Macro as the command and click the macro name to define a new macro:

    enter image description here

  3. Click Create a new Macro.

  4. Create a macro named F2 and insert a F2 key press into the editor:

    enter image description here

  5. Make sure the F2 macro is selected for the key.

share|improve this answer
    
and repeat that for every key? –  javapowered Jul 11 '13 at 14:25
    
@javapowered: Right –  Oliver Salzburg Jul 11 '13 at 15:51

At this site, you can find a modified commands.xml file. To use this modified file, place it in the directory that Intellitype Pro is installed to (typically, this would be C:\Program Files\Microsoft IntelliType Pro).

If you wish to revert the changes, is included the original commands.xml file (just rename it from commands.original.xml to commands.xml).

Intellitype Pro is feature added software that allows a user to reprogram various keys on their Microsoft keyboard.

See this article that explains how to do this by registry editor.

share|improve this answer
    
this example is very old and likely is not fully compatible with the latest version of keyboard driver, at least it seems so from the diff of provided file and one from my filesystem. –  javapowered Jul 11 '13 at 14:30
    
@javapowered It should work. If you're really concerned, just backup the current commands.xml, try out Jason Tsangs, and if that doesn't work, restore the original. –  ernie Jul 11 '13 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.