Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a mid-2012 Macbook Air 11" with a 128GB SSD. On it have two installs of OS X. One of Mountain Lion (10.8) and one of Mavericks (10.9). I want to remove the Mountain Lion install so I can use the entire SSD for Mavericks (10.9). Initially, I only wanted to test Mavericks (10.9), but later decided to use it as my main OS, since I didn't notice any bugs.

I have transferred all my files over to Mavericks (10.9), so all I need to do is delete to Mountain Lion (10.8) partition and expand the Mavericks (10.9) partition to take advantage of the entire SSD.

I tried deleting the Mountain Lion (10.8) partition in Disk Utility (from Mavericks (10.9)), but it didn't let me do that. It could not deactivate the disk.

After deciding to use Mavericks (10.9) as my main OS, I realized 60GB is a little bit to small, and having another 60GB unused is simply not any clever.

share|improve this question
    
you probably have some shared application(s) on the 10.8 partition that is preventing Disk Utility from unmounting it. Have you tried getting rid of the 10.8 side through Boot Camp? –  MattDMo Jul 11 '13 at 15:55
    
I might have some shared applications. I'll check on that in a few minutes. I have not tried Boot Camp, because that's for Windows and Windows is not associated with this issue. I do not have Windows installed either. P.S. Is there an easy way to check if I have shared applications and what applications? –  TrulsBekk Jul 11 '13 at 16:04
    
After deleting all applications from 10.8, I got to delete that partition from Disk Util in 10.9, but now I can't expand the 10.9 partition to fill the entire SSD. –  TrulsBekk Jul 11 '13 at 16:17
    
is this before or after rebooting? That might do the trick... –  MattDMo Jul 11 '13 at 16:19
    
I tried to expand the partition both before and after rebooting. –  TrulsBekk Jul 11 '13 at 17:47
show 1 more comment

1 Answer

The issue is likely due to your partition map. You can't expand partitions upwards in disk utility; you can only expand them downwards.

So, assuming 10.8 was on the Mac to begin with, that would have been your primary boot partition, disk0s2. If you added another partition, it would likely be disk0s4 (s3 being reserved for the Recovery partition). You can't expand disk0s4 to overtake disk0s2. You'd have to re-partition your drive.

In summary, if you added 10.9 alongside the 10.8 that was already installed, and then want to use 10.9, you'll have to either install 10.9 on top of 10.8 (and then remove your 10.9 partition to have a full disk again), or boot to the recovery partition, repartition your drive, then use a 10.9 installer on an external drive to install 10.9.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.