Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having problems printing to the printer connected to my (SBS2003) business's network.

I know the IP of the printer and I can ping it and even print files from it by going to in firefox and uploading a file.

If I do an nmap on the IP of the printer I get this:

jamesmaddison@development:~$ nmap

Starting Nmap 5.21 ( ) at 2013-07-11 16:12 BST
Nmap scan report for
Host is up (0.46s latency).
Not shown: 991 closed ports
21/tcp    open  ftp
23/tcp    open  telnet
80/tcp    open  http
443/tcp   open  https
515/tcp   open  printer
631/tcp   open  ipp
5900/tcp  open  vnc
9100/tcp  open  jetdirect
50001/tcp open  unknown

Nmap done: 1 IP address (1 host up) scanned in 4.55 seconds

I can't get my local cups server to print to it no matter what protocol I use. I am in the business workgroup and the printer even lists my computer in the workgroup.

The Printer is a Sharp MX-M314N. All Windows computers on the network can print to it fine, just my ubuntu machine that won't.

Here's what the CUPS error log says for the last job I tried.

E [11/Jul/2013:16:21:28 +0100] [cups-polld MASTERMAGNETS:631] Unable to connect to MASTERMAGNETS on port 631.

Here's what nmap reports when I run it on the SBS

jamesmaddison@development:~$ nmap mastermagnets

Starting Nmap 5.21 ( ) at 2013-07-11 16:35 BST
Nmap scan report for mastermagnets (
Host is up (0.00055s latency).
rDNS record for mastermagnets.local
Not shown: 957 closed ports
25/tcp    open  smtp
42/tcp    open  nameserver
53/tcp    open  domain
80/tcp    open  http
88/tcp    open  kerberos-sec
135/tcp   open  msrpc
139/tcp   open  netbios-ssn
389/tcp   open  ldap
443/tcp   open  https
444/tcp   open  snpp
445/tcp   open  microsoft-ds
464/tcp   open  kpasswd5
593/tcp   open  http-rpc-epmap
636/tcp   open  ldapssl
691/tcp   open  resvc
1025/tcp  open  NFS-or-IIS
1027/tcp  open  IIS
1042/tcp  open  unknown
1045/tcp  open  unknown
1046/tcp  open  unknown
1048/tcp  open  unknown
1049/tcp  open  unknown
1054/tcp  open  unknown
1081/tcp  open  unknown
1087/tcp  open  unknown
1094/tcp  open  unknown
1104/tcp  open  unknown
2301/tcp  open  compaqdiag
2381/tcp  open  unknown
3268/tcp  open  globalcatLDAP
3269/tcp  open  globalcatLDAPssl
3389/tcp  open  ms-term-serv
5633/tcp  open  unknown
6001/tcp  open  X11:1
6002/tcp  open  X11:2
6004/tcp  open  X11:4
6101/tcp  open  backupexec
6106/tcp  open  isdninfo
8080/tcp  open  http-proxy
8081/tcp  open  blackice-icecap
8082/tcp  open  blackice-alerts
8443/tcp  open  https-alt
10000/tcp open  snet-sensor-mgmt

Nmap done: 1 IP address (1 host up) scanned in 1.18 seconds
share|improve this question

You are trying to print to your Windows server ( Just print to the network printer( directly.

share|improve this answer
CUPS is setup to print to socket:// though. – Lerp Jul 11 '13 at 19:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.