Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In order to run this game, it says I need to be using 10.7.4 or later. So I changed the SystemVersion.plist file to 10.7.4, and it still gives me the error message, even though it says I have 10.7.4. I am running 10.6.8.

share|improve this question
1  
You will have to simply update your system to 10.7.4 there are far to many checks to "trick" software into running. –  Ramhound Jul 11 '13 at 16:35
4  
Also, software doesn't put a version requirement just for the fun of it. If they went through the trouble of saying that their software requires 10.7.4, then there is something in 10.7.4 that their software needs to function. –  Darth Android Jul 11 '13 at 16:39
    
so you are saying I cant run it on my Mac classic? –  Keltari Jul 11 '13 at 19:09
add comment

2 Answers

You obviously need 10.7.4 for whichever program, it is near to impossible to trick a system into thinking it's a different version. Whichever way it probably needs something in 10.7.4, the system requirements aren't just there for the LOLs. Just update!

share|improve this answer
add comment

Like all OS companies, Apple releases new code, new APIs in their software at a regular rate. What most likely happened is the code uses the BrightAndShinyFunction() that was just released in 10.7.4. The code will check for the presence of BrightAndShinyFunction(), and it will bail if its not there.

You can't just fake this. You changing the version string won't make the "Check for BrightAndShinyFunction()" work. You need to update. 10.8 has been out for a while. 10.9 (Mavericks) is in beta. If your Mac supports 10.7, you really should update to 10.7 at least. 10.6 is showing its age. It's about $20, though I do think you need to call Apple to get 10.7... only 10.8 is available directly from the Mac App store.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.