Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a workflow where I modify files in XPMode on a Windows 7 machine, copy the modified files to a mapped computer (to a folder on the Windows 7 C drive), and then from there, in Windows 7 (outside of XPMode) copy them from that "holding tank" to a mobile device attached via Active Sync to the Windows 7 machine.

This has worked fine for several months, now (and still "works"), but today the following strange thing occurred:

I modified the files in XPMode and copied them to the holding tank folder on the Windows 7 host. As always, it asked me if I wanted to replace the existing files of the same name (an .exe and a .dll); as always, I replied "yes" to that.

This time, though, when I opened Explorer in Windows 7, the files showed the modified date/time of the previous files, even after mashing F5 to refresh.

Nevertheless, I copied those files to the WindowsCE device via Explorer, agreeing to "Copy and Replace" the existing files there, though they ostensibly were the same (had the same modified date/timestamp). BUT, when I then viewed those files in Explorer in the folder beneath WindowsCE into which I had copied them, they showed the NEWER date. And they were those newer files, as the changes I had made did manifest themselves in the way the app worked on the WindowsCE device.

Why would the "holding tank" folder in the Windows 7 folder refuse to expose the correct modified date?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.