Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to ssh/sftp to my Mac at home, from office.

I can ping it fine. I'm pretty sure I set up keys correctly with ssh-keygen

Here's what I'm getting (private info masked with •••):

Edit07:.ssh zeev$ ssh -vvv dzg@•••.dyndns.tv
OpenSSH_5.6p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to •••.dyndns.tv [76.•••.62] port 22.
debug1: Connection established.
debug3: Not a RSA1 key file /Users/zeev/.ssh/id_rsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /Users/zeev/.ssh/id_rsa type 1
debug1: identity file /Users/zeev/.ssh/id_rsa-cert type -1
debug3: Not a RSA1 key file /Users/zeev/.ssh/id_dsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /Users/zeev/.ssh/id_dsa type 2
debug1: identity file /Users/zeev/.ssh/id_dsa-cert type -1
ssh_exchange_identification: Connection closed by remote host
share|improve this question
    
secure.log shows Jul 11 12:34:31 MacPro sshd[96484]: error: BSM audit: getaddrinfo failed for UNKNOWN: nodename nor servname provided, or not known Jul 11 12:34:31 MacPro sshd[96484]: Could not write ident string to UNKNOWN –  Ze'ev Jul 11 '13 at 19:37
    
The message in line 8 says all: not a rsa1 keyfile. Have you converted it to ppk-format? –  ott-- Jul 11 '13 at 19:40
    
@ott Not that I know of ... and I just generated the keys locally. –  Ze'ev Jul 11 '13 at 19:56
    
Do you remember the options to ssh-keygen you've used? –  ott-- Jul 11 '13 at 20:00
    
I did 3 -- rsa, rsa1, and dsa –  Ze'ev Jul 11 '13 at 21:15
add comment

1 Answer 1

It looks like you're using the wrong version of your SSH key.

Assuming you're running Mac OS X at work (or any other UNIX/Linux variant) run the following: ssh-keygen -t rsa and specify ~/.ssh/home as your path - this will allow you to use your default id_rsa key for work purposes should you need to. Then: cat ~/.ssh/home.pub and paste the key into the ~/.ssh/authorized_keys file on your home Mac.

If you're running Windows, use PuTTYgen to regenerate your key, but this time copy the 'OpenSSH' public key (in the scrollable window at the top) into the ~/.ssh/authorized_keys file on your home Mac. Then load the PPK version of your key into PuTTY's agent.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.