Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Oracle VirtualBox on Windows 8. Then I downloaded android-x86-4.2-20121225.iso from Android-x86.

After I installed Android x86-4.2 on VirtualBox from the ISO, I could run it, but the Internet is not working.

What can I do to troubleshoot this or get Internet connectivity?

Update:- (1) I try it In VB, changing NAT connection settings to: AMD PCNet FAST III (Am79C973) but still not working

(2) I use other OS like windows XP with NAT connection settings to: AMD PCNet FAST III (Am79C973) setting that work nice like internet and everything. so plz give me a other option for android-x86-4.2-20121225 to connect internet ??

share|improve this question

2 Answers 2

In VB, try changing NAT connection settings to:


The Intel settings don't ever work for me.

To change it:

  1. Select the Virtual Machine from the list.
  2. Click the gear icon labeled Settings.
  3. In the window that opened, select the tab Network.
  4. Make sure adapter one is enabled by ticking the box at the top.
  5. At the drop down menu Attached to, select NAT.
  6. Click the small blue arrow with the label Advanced if not already done.
  7. Change the Adapter Type to AMD PCNet FAST III (Am79C973)
  8. Hit Okay and run the virtual machine again.

enter image description here

share|improve this answer
Well this didn't work for me , in WIndows 8 Oracle VM 4.3 for 4.4kitkat image. :-( – Soundararajan Dec 26 '14 at 11:45

enter image description here

For android kitkat 4.4 enable nat for network adapter and "Paravirtualized Network(virtio-net)" for the adapter type.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.