Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am attempting a Remote Desktop Session

From OSX 10.8.4
To Windows Server 2012 DataCenter R2(Build 9431)

I am using 2.1.1 Remote Desktop client for Mac

I have disabled Network Level Auth, although in 2008R2 it works fine.

I have set "always Connect, Even if Auth Fails on the Client

MSTSC.EVE bin is able to connect to the machine.

Other window machines work fine enter image description here

share|improve this question
    
You can connect fine from other Windows boxes? –  dtmland Jul 12 '13 at 19:33
    
Other windows hosts work fine & WineWrapped mstsc.exe within OSX works fine. My OSX RDP client to 2k8R2 hosts work fine –  Xiuhtecuhtli Jul 12 '13 at 19:37
    
Have you tried the FQDN of the 2012 server to see if there's any difference? –  john Jul 17 '13 at 22:11
    
FQDN, NetBIOS and IP all have the same results. –  Xiuhtecuhtli Jul 18 '13 at 6:21
add comment

3 Answers 3

Watch out - the old OS X Microsoft Remote Desktop (version 2.1.1) that comes with Mac Microsoft Office 2011 no longer works with Windows 2012 R2 (it does work with plain old Windows 2012). For me it fails with the following error message:

Remote Desktop Connection cannot verify the identity of the computer that you want to connect to.

A (regular) Windows 2012 Remote Desktop client doesn't have this problem.

(Brief aside - Microsoft have a little note that says the 2.1.1 client is not supported on OS X v10.7 or later. Who knew and why did it make me report all those crashes?)

The good news is that the new OS X Microsoft Remote Desktop 8.0.24091 (Mac App store only though - grr) does work with Windows 2012 R2 . Why this information isn't listed on the What's New in 2012 R2 Remote Services page I don't know...

(If you wish to make the old client work you can follow the steps to get Mac RDP client 2.1.1 (110309) working or try the 2.1.2 unreleased build of the old client (please someone edit this answer))

share|improve this answer
1  
Fantastic Thank you. I wish you got the +50 –  Xiuhtecuhtli Oct 20 '13 at 19:12
add comment

According to Microsoft's Download Center page, the Remote Desktop Connection client for Mac was last updated on 5/5/2011, over 2 years ago. As it says, "Microsoft Remote Desktop Connection Client for Mac (version 2.1.1) is not intended for use with Mac OS X v10.7 (Lion) or later."

Also note that that page does not list Windows Server 2012 at all under the "System Requirements."

I would suggest using a newer client (e.g. I use CoRD which supports OS X 10.5-10.8), as there may be unexpected behavior from using Microsoft's old software.

share|improve this answer
    
Thank you. CoRD seems to be working for my needs. –  Xiuhtecuhtli Jul 19 '13 at 22:00
add comment

For those of you still using the old RDP application, doing the following helps:

Enable RDP security layer in Group Policy on the machine:

  1. Verify that the firewall allows remote desktop connections with RDP (Port 3389)
  2. Click Start>Run Type gpedid.msc and click "OK"
  3. The Group Policy Editor will open In the left hand side bar, expand Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services>Remote Dekstop Session Host
  4. Select Security Change Require use of specific security layer for remote desktop (RDP) connection" to Enabled and select RDP in the Options pane.
  5. Change Require user authentication for remote connections by using Network Level Authentication to Disabled.
  6. Close Group Policy Editor and reboot the machine for changes to take effect.

I don't know if this is an unsecured way of doing it but for my home network I did not mind changing the settings. I got the above from here.

I was using the new RDP client and it was working well until a recent update happened and it lost all my connections. More annoyingly it does not store the connections I create and shows a "new features popup" every time I open the app though it is not new anymore. Until I fix this issue, I'll be using the old client.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.