Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some software which runs on windows. I installed wine and ran it in linux. It works fine but the issue is it communicates with a serial port. Therefore the only option I can choose are com1,com2,.... But my device on the linux machine is actually located at the /dev/ttyUSBn location. How do I use the above software in linux ubuntu?

I have tried ln -s /dev/ttyUSBn COM1 in the ~/.wine/dosdevices/. it does not appear to work.

share|improve this question

1 Answer 1

Symlinks should work; however, they must be located in ~/.wine/dosdevices/, not in any random directory. The WineHQ article also shows the names in lower-case.

4.3.1. Serial and Parallel Ports

Serial and parallel port configuration is very similar to drive configuration - simply create a symbolic link in ~/.wine/dosdevices with the name of the device. Windows serial ports follow a naming convention of the word "com" followed by a number, such as com1, com2, etc. Similarly, parallel ports use "lpt" followed by a number, such as lpt1. You should link these directly to the corresponding Unix devices, such as /dev/ttyS0 and /dev/lp0. For example, to configure one serial port and one parallel port, run the following commands:

ln -s /dev/ttyS0 com1
ln -s /dev/lp0 lpt1
share|improve this answer
    
Yes. Thats definitely where I put it. I also tried changing the permissions of the com files and also added the registry edits according to the wiki. I still have no luck –  Sab Jul 14 '13 at 3:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.