Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I uninstalled my browser (iceweasel) from Add/Remove Software option in Kali Linux.At the time of removal it asked for one dependent package also to be uninstalled that I don't remember.

But now when I am re-installing it as per instruction given on its official Site , it's giving the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package iceweasel is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package 'iceweasel' has no installation candidate

Any suggestions !!!

share|improve this question
    
Post the command return: apt-cache search iceweasel --names-only. –  DBX8 Jul 14 '13 at 12:37
    
@TiagoCA : This command gave no result. –  wek Jul 14 '13 at 12:39
    
OK, check the output of apt-cache policy iceweasel. –  DBX8 Jul 14 '13 at 12:46
    
iceweasel: installed:(none) candidate: (none) version table:18.0.1-1 0 100 /var/lib/dpkg/status –  wek Jul 14 '13 at 12:51
add comment

1 Answer

In order to correct a system with broken dependencies in place, try:

apt-get-f install

And retry:

dpkg --configure iceweasel
share|improve this answer
    
i have already done update & upgrade , but no effect –  wek Jul 14 '13 at 12:56
    
It's giving following error : dpkg: error processing iceweasel (--configure): package iceweasel is not ready for configuration cannot configure (current status `config-files') Errors were encountered while processing: iceweasel –  wek Jul 14 '13 at 13:05
    
any other suggestion? –  wek Jul 14 '13 at 13:28
    
@wek: Sorry for the delay, check my answer. –  DBX8 Jul 14 '13 at 14:27
    
Still no luck bro.Same error as I mentioned above :(. If their is any way I can totally remove all package related to it and reinstall ? –  wek Jul 14 '13 at 14:38
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.