Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with setting up my wireless connection. Recently I have installed Arch Linux on my machine without setting wireless at all (I used wired connection). Now, I want to configure my wireless connection but I when I try to turn it on:

idea-arch ~ # ip link set wlp8s0 up
RTNETLINK answers: Operation not possible due to RF-kill

Here are some outputs:

idea-arch ~ # ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT   qlen 1000
link/ether dc:0e:a1:7d:af:5f brd ff:ff:ff:ff:ff:ff
6: wlp8s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
link/ether 74:e5:0b:cc:80:ba brd ff:ff:ff:ff:ff:ff

idea-arch ~ # rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
5: phy3: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

I have tried using Fn+F5 but it leads only to soft block. Also, I have tried rmmod iwlwifi and rmmod iwldvm while I have my hardware switch on laptot off. Then I turn it on my laptot and did modprobe iwlwifi and modprobe iwldvm - still no success.

I am using Lenovo Ideapad Y570, shiped with Windows 7 but reinstall to only Arch Linux machine. My network adapters according to lspci|grep -i net are:

idea-arch ~ # lspci|grep -i net
07:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57781 Gigabit Ethernet PCIe (rev 10)
08:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]

I am sure that hardware switch is on. What else can I do? Thank you for any answer

share|improve this question
add comment

3 Answers

Install the packages:

#pacman -S iw wpa_supplicant wpa_actiond dialog

After finishing, you can connect to the network with wifi-menu interface_name (where interface_name is the interface of your wireless chipset).

# wifi-menu interface_name
share|improve this answer
    
I tried this but this is output:idea-arch ~ :( # wifi-menu wlp8s0 Scanning for networks... failed No networks found –  phandox Jul 14 '13 at 19:15
add comment

I used to have the same problem on a old Toshiba laptop and Archlinux (no way to disable the "Hard block").

I never managed to make it work...until I installed Gnome Shell/Gnome 3 (and of course the networkmanager demon). In the network settings I was able to enable it, and it works. I didn't search why the gnome thing worked and the other tool didn't, as it solved my problem !

So maybe you can try that.

share|improve this answer
    
Sorry for late answer. I have installed Gnome3 and from GUI I tried to set the wifi on but, it says that hardware switch is off :( I have read that this laptot wifi is somehow linked to windows Lenovo app so maybe the thing that I have the wifi turned off during uninstalling win and installing arch made this hardware switch off. I may try reinstalling windows again, turn on wifi and then install arch again.. –  phandox Jul 17 '13 at 7:10
add comment
up vote 0 down vote accepted

As I was afraid, here is the solution. I had to install Win 7 again, install Lenovo Energy Management Utility, turn on wifi on windows and then, Hard Block disapear. Now it works like a charm. Hope this helps someone with same laptop.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.