Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a single operating system (Ubuntu). When I start my computer, I get a black screen, and after a few seconds, the Ubuntu loading screen, and after that I'm able to use my computer as usual. I do not get the BIOS loading screen. I've tried F2 and F12 (which are the keys used in Toshiba Satellite, my laptop) while the black screen shows to enter BIOS setup, but those don't work.

How do I fix this? I've already reinstalled Ubuntu (not because of this) and the problem still persists, though I doubt that Ubuntu is the problem.

EDIT: My questions is not how to enter the BIOS setup - I know how to do that. The problem is that I don't even get the usual loading screen that says "TOSHIBA" and "Press F12 to enter setup". My computer, on being turned on, directly shows the Ubuntu loading screen

share|improve this question
    
    
I've already tried that - that's not the problem. I assume that the OP there gets the BIOS screen that shows the laptop model and instructions to enter BIOS setup. I don't even get that. –  asymptotically Jul 15 '13 at 7:15
    
The key sequence to enter the BIOS after power up depends on the PC. What make & model is your PC? Have you tried reading the manual for your PC? –  sawdust Jul 15 '13 at 9:44
    
Toshiba Satellite, and yes. I've entered the BIOS many times before (mostly to change boot sequence). This is a recent problem –  asymptotically Jul 15 '13 at 9:54
    
Again, there is a deeper problem as the screen that says "TOSHIBA" and "Press F12 to enter setup" doesn't even show - my computer directly goes to the Ubuntu loading screen –  asymptotically Jul 15 '13 at 9:55

3 Answers 3

up vote 1 down vote accepted

You may have inadvertantly selected a "quick boot", "boot logo" or similar setting, which replaces the BIOS' normal output with a graphical image and might skip certain checks to make the system boot faster. But I find it hard to see that something like that would have changed without you actively doing anything to the BIOS.

Removing the CMOS battery, or using a "CLEAR CMOS" jumper on the motherboard (at least on full-sized motherboards there is usually one that can be set to either "normal" or "clear"/"reset"), would be the first thing I try. You'll lose all BIOS settings, including the system date and time, but once you get into the BIOS setup a "restore to factory defaults" or similar should be all that is needed to bring the settings to reasonable values. Remember to reset the system time afterwards, preferably before booting (some things may be upset when the system time makes sudden jumps of many years). Note that since you have a single-boot Linux system the OS may be configured to read the system clock as UTC rather than local time.

Clearing the CMOS memory by any means will usually force you to enter the BIOS setup on the next boot, because then the internal data checksum won't match.

share|improve this answer
1  
Thank you! You were right, I had enable 'Fast Boot' and forgotten about it, because I anyway had only one operating system. I didn't know that would skip system checks, so I've disabled it. On Toshiba, if you press and hold F2 before turning your laptop on, it goes to the BIOS setup. –  asymptotically Jul 15 '13 at 12:18
1  
@asymptotically Exactly what Fast Boot mode does varies from system to system, but unless the few additional seconds spent doing the Power-On Self Test (POST) are a major problem for some reason, I tend to set all relevant BIOS settings to "take your time and show what you are doing" values. It doesn't bother me (and less tech-savvy people will just see some text flash by briefly) and it makes diagnostics much easier if something goes wrong. –  Michael Kjörling Jul 15 '13 at 12:22

There are more ways to open the BIOS, depending on what company developed it. Have you tried all of these? (Or at least those by your system's manufacturer

Might be that you somehow disabled the BIOS from showing at boot, and you should be able to re-enable it in the BIOS itself (using whatever key combination, see link above)

share|improve this answer
    
Yes, I've tried them all –  asymptotically Jul 15 '13 at 7:40
    
Does your system have PS/2 connections? Sometimes you can only access BIOS using these instead of USB keyboard –  Tom Vandenbussche Jul 15 '13 at 7:45
    
Or have you tried booting with the keyboard unplugged? –  Tom Vandenbussche Jul 15 '13 at 7:46
    
Only my touchpad. It's a laptop –  asymptotically Jul 15 '13 at 7:46
    
I'm unabke to even see the BIOS loading screen, which I could just a few weeks back –  asymptotically Jul 15 '13 at 7:48

Try to remove your battery for a few seconds and then try to reboot your PC. As soon as it starts try to get to the BIOS CP by pressing the BIOS CP buttons. They will likely be ESC, F2, F10 and DEL.

share|improve this answer
    
Already tried - see the other answer. –  asymptotically Jul 15 '13 at 9:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.