Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a total newbie in Oracle.

I installed Oracle 11g XE R2. Also I installed SqlDeveloper 3.2.20.09 version.

I generated auto connections, and I have 2 connections. One is: /as sysdba and another: system-XE

I successfully connect to system-XE, but when I try to connect as sysdba in SQLdeveloper (in same time I can connect trough SQL command line) I get this error:

java.lang.Error: Incompatible version of libocijdbc[Jdbc:112030, Jdbc-OCI:112020
at oracle.jdbc.driver.T2CConnection$1.run(T2CConnection.java:3557)
at java.security.AccessController.doPrivileged(Native Method)
at oracle.jdbc.driver.T2CConnection.loadNativeLibrary(T2CConnection.java:3550)
at oracle.jdbc.driver.T2CConnection.logon(T2CConnection.java:266)
at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:552)
at oracle.jdbc.driver.T2CConnection.<init>(T2CConnection.java:162)
at oracle.jdbc.driver.T2CDriverExtension.getConnection(T2CDriverExtension.java:53)
at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:526)
at oracle.jdeveloper.db.adapter.AbstractConnectionCreator.getConnection(AbstractConnectionCreator.java:153)
at oracle.dbtools.raptor.standalone.connection.RaptorConnectionCreator.getConnection(RaptorConnectionCreator.java:195)
at oracle.dbtools.raptor.dialogs.conn.ConnectionPrompt.promptForPassword(ConnectionPrompt.java:67)
at oracle.jdeveloper.db.adapter.DatabaseProvider.getConnection(DatabaseProvider.java:321)
at oracle.jdeveloper.db.adapter.DatabaseProvider.getConnection(DatabaseProvider.java:254)
at oracle.jdevimpl.db.adapter.CADatabaseFactory.createConnectionImpl(CADatabaseFactory.java:60)
at oracle.javatools.db.DatabaseFactory.createConnection(DatabaseFactory.java:534)
at oracle.javatools.db.DatabaseFactory.createDatabase(DatabaseFactory.java:208)
at oracle.jdeveloper.db.DatabaseConnections.getDatabase(DatabaseConnections.java:607)
at oracle.dbtools.raptor.utils.Connections$ConnectionInfo.getDatabase(Connections.java:172)
at oracle.dbtools.raptor.utils.Connections.getConnection(Connections.java:1064)
at oracle.dbtools.raptor.utils.Connections.getConnection(Connections.java:1045)
at oracle.dbtools.raptor.navigator.DatabaseConnection.openConnectionImpl(DatabaseConnection.java:115)
at oracle.dbtools.raptor.navigator.AbstractConnectionNode.getConnection(AbstractConnectionNode.java:30)
at oracle.dbtools.raptor.navigator.ConnectionFilter.getFactory(ConnectionFilter.java:94)
at oracle.dbtools.raptor.navigator.ConnectionFilter$1.doWork(ConnectionFilter.java:119)
at oracle.dbtools.raptor.navigator.ConnectionFilter$1.doWork(ConnectionFilter.java:104)
at oracle.dbtools.raptor.backgroundTask.RaptorTask.call(RaptorTask.java:193)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at oracle.dbtools.raptor.backgroundTask.RaptorTaskManager$RaptorFutureTask.run(RaptorTaskManager.java:515)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)

any help would be really appreciated since now I was searching for the solution almost 3 hours.

share|improve this question

migrated from stackoverflow.com Jul 15 '13 at 10:02

This question came from our site for professional and enthusiast programmers.

    
Try upgrading Java to latest version, there are some incompatibilities, according to your log. –  David Jashi Jul 14 '13 at 20:37
    
I have Version 7 Update 25 so :/ –  julie smith Jul 14 '13 at 20:39
    
How are you trying to connect? Can you provide a minimal example of code that causes this error? –  Ben Jul 14 '13 at 21:01
    
I have default OS authentication for sysdba, and I only tried to connect as usual in SqlDeveloper. It works for other connections, but not for the sysdba since it it OS authentication (probably that is the resion). –  julie smith Jul 14 '13 at 21:03
add comment

3 Answers 3

The first error message seems to be reasonably clear:

java.lang.Error: Incompatible version of libocijdbc[Jdbc:112030, Jdbc-OCI:112020

For whatever reason, the version of libocijdbc which is being found (apparently version 112020) is not compatible with the jdbc version found (112030). You might want to consider tracking down version 112030 of libocijdbc, or switching things around so that version 110230 of libocijdbc is found first.

Share and enjoy.

share|improve this answer
add comment

[https://community.oracle.com/thread/2346683?tstart=0][1]

... 1. create tnsnames.ora file

  1. Open SQL Developer and set tnsnames directory tools->Preferences->Database->advanced->Tnsnames Directory

  2. In SQL Developer, UNCHECK: tools->Preferences->Database->advanced->use oci/thick driver

  3. new connection connection type TNS -> Network Alias (pick from list)

  4. try connection ...

share|improve this answer
add comment
up vote 0 down vote accepted

I've solved it. In the sqldeveloper/jdbc/lib folder replace the ojdbc6dms.jar and ojdbc6.jar files with the same files, but version Oracle Database 11g Release 2 (11.2.0.2.0) JDBC Drivers :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.