Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently got a strange problem with privoxy when using apt-get (or aptitude) to fetch new package lists. This is especially strange since it worked fine for several months...

I'm running Ubuntu 13.04 on a laptop which is moving between several networks some of which have a proxy and some don't. So I'm using privoxy to quickly switch between different proxy settings without having to fuddle with dozens of program settings (browser, IDE, environment...). Since this is the sole purpose of my usage of privoxy the settings are 99% vanilla only containing some forward-rules. Nothing fancy what so ever is turned on beyond the defaults.

For some days now fetching new package lists with apt-get did not work properly. Fetching the headers took so long apt-get timed out. After modifying the proxy settings (in /etc/apt/apt.conf) to directly go through the company proxy it suddenly worked like a charm.

Any suggestions how to fix this? I'd like to stick with a simple, single-point solution to switch between proxy settings.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.