Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All the tutorials and guides I have seen about accessing remote desktop in virtualbox claim that it is extremely easy yet I keep getting errors. Every time I try to access the virtualbox client running Arch Linux I get the standard error:

Remote Desktop can't connect to the remote computer for one of these reasons: 1) Remote access to the server is not enabled 2) The remote computer is turned off 3) The remote computer is not available on the network

Hence I started troubleshooting this. First I checked that the remote access is enabled enter image description here

Isn't that enabled?

Second was whether the amchine is one: well it was and I even had X running (I an at the early stages of Arch Linux installation) so that can't be the reason.

Thirdly I checked whether the computer is availabe through the network which I did my pinging the guest machine (the network adapter is on bridged mode) and since I got a response I surmised that the machine is working and at the same workgroup as the rest of my lan machines.

So to recap: - Virtualbox settings say remote display is enabled - The machine is on - Machine is accessible from the network

Yet still I am unable to log in. I have tried disabling the firewall on both the machine I am connecting from and the machine that hosts the virtualbox to no avail.

enter image description here

So any thoughts just what is it I am doing wrong?

share|improve this question
try to connect to that IP/port with netcat or telnet to see if at least a connection can be made to that port – golimar Jul 15 '13 at 12:36
up vote 1 down vote accepted

When using the Remote Display feature you have to connect to the host on port 5000 and not to the guest.

So try to connect to the host on port 5000.

Therefore the networksetup of the guest (wheter bridged or not) does not matter.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .