Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running a Lenovo Thinkpad T61 with an Intel Core 2 Duo T7300 processor. When I run Virtual PC in Windows 7, I get the following error:

Unable to start Windows Virtual PC because hardware-assisted virtualization is disabled.

When running the Hardware-Assisted Virtualization Detection Tool from Microsoft says:

Hardware-assited virtualization is not enabled on this computer.

Now, in the BIOS, I do have virtualization enabled and according to Intel this processor supports Intel-VT. What am I missing here?

share|improve this question
    
Do a CPUID check and also update to the latest BIOS. Lenovo notebooks do sometimes come with VT-X disabled (not too sure why your BIOS says it's enabled, and it does not work.) –  caliban Oct 28 '09 at 14:27

3 Answers 3

up vote 4 down vote accepted

Enabling Intel-VT requires a cold restart. Try going back into the BIOS, turn it off, and turn off the computer (don't just reboot). Then start up, go in the BIOS and enable it, then once again turn the PC off. Make sure you save your changes in the BIOS.

Boot up and start VPC, check the options and ensure it is enabled:

alt text

share|improve this answer
    
I don't recall if I powered off after enabling VT in the BIOS a few days ago. I will give that a shot... –  dlux Oct 28 '09 at 14:32
    
Well, that was the problem. Powered off and back on, and now Virtual PC is working. –  dlux Oct 28 '09 at 14:46

There is now a second way to resolve this problem. Microsoft released an update to Virtual PC which removes the requirement for hardware assisted virtualization.

http://blogs.msdn.com/virtual_pc_guy/archive/2010/03/18/windows-virtual-pc-no-hardware-virtualization-update-now-available-for-download.aspx

share|improve this answer

Perhaps a stupid suggestion, but have you checked if there's a Bios update where this problem might be fixed?

share|improve this answer
    
It looks like I am on the latest revision from Lenovo. –  dlux Oct 28 '09 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.