Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Alright, I realize this isn't a professional server question, but this seemed like the most appropriate place to ask.

I'm working on some web design projects and I've been dissatisfied with many of the free servers I have tried. I don't want to pay for a server service because most of the projects I'm working on are really just for learning purposes, as a result I decided to try and set up my own server with an old Macbook Air.

  1. I went into my Sharing settings and turn on web sharing, then proceeded to turn on the firewall for extra security.

  2. After this I went into my router(Arris) settings and enabled DMZ for that computer, which opened up port 80. I then set up port forwarding and port triggering

  3. From here I went to No-IP.com and set up an account, where I signed up for a subdomain name and then added a host where I selected the DNS Host(A) option.

  4. Lastly, I downloaded their client update manager and set it up to where it "should" work.

The issue though, is that when I type in the subdomain that I setup, it just says page cant be found. What am I missing, clearly there is a step i have overlooked. Is there anyone here who has dealt with no-ip.com, or at least know what I need to do to get this going?

share|improve this question

migrated from serverfault.com Jul 15 '13 at 23:34

This question came from our site for professional system and network administrators.

1  
Suggestions: Nobody hosts websites on OSX (Apple.com is run on Linux). Use Windows/IIS or *nix/Apache/nginx/etc. Run the "server" in a VM using VirtualBox or similar. There are guides around to walk you through the process. Check out Super User, Unix & Linux, and Ask Different for more help too. As for the "problem", your router almost certainly can't hairpin NAT. Also, hosting websites on a MBA is a terrible idea and a good way to get a virus. –  Chris S Jul 15 '13 at 23:34
    
as for nobody hosting websites on osx, that would be wrong, plenty of people do. and Apache (Web sharing) runs just fine on OSX. That being said there are a lot of of moving parts The first and foremost question I have is are you trying to hit it via your external IP address from inside your network since lots of routers/devices cannot hairpin traffic. Have you tried something something like downforeveryoneorjustme.com to test it from the outside –  Doon Jul 15 '13 at 23:41
1  
@chriss could you please explain why hosting a website on a MBA is a good way to get a virus. While I agree an air isn't the ideal hosting platform, but I don't see how virus play into it. –  Doon Jul 15 '13 at 23:44
    
@Doon When I set up the port forwarding I used my Private IP address. And according to that site, it's down. After rereading your question i think I might have answered you incorrectly. I have tried logging on from outside my network, using a friends computer in another location. –  Jcmoney1010 Jul 15 '13 at 23:46

1 Answer 1

NAT is your issue.

Your subdomain is resolving to a public IP, but you can't get to it unless you are outside your network.

Internally, use the private IP your server is running on. When outside your network, i.e. when telling others to test, use your subdomain.

When you are configuring web apps, you may run into problems if some apps want to do URL rewriting - you're going to want to use your subdomain here, but things may break if you access internally. Another thing to do is add the following to your /etc/hosts:

yoursubdomain.ip.com X.X.X.X

where X.X.X.X is the internal IP of your server. You'll have to do this on at least your server and the system you are using to test it with, if they are separate systems.

share|improve this answer
    
Thanks for the reply, but I have been trying to access the subdomain from outside my network, and it doesn't work. From inside my Network, I can access the site by using my private IP. The issue is that I can't access the site from outside the network. –  Jcmoney1010 Jul 16 '13 at 0:15
    
Are you running an update client? (Which I see that you are ...) Does No-IP have your correct external IP? (Log into No-IP web interface and verify) –  ultrasawblade Jul 16 '13 at 0:16
    
Yes, it does. I keep manually updating the client as well to make sure that it is always up to date. –  Jcmoney1010 Jul 16 '13 at 0:18
    
"I went into my Sharing settings and turn on web sharing, then proceeded to turn on the firewall for extra security. " - Is this on your router or the computer? If it's on the computer, make sure port 80 is allowed in both directions. –  ultrasawblade Jul 16 '13 at 0:19
    
I turned on the Sharing settings through my computer then I went through my router and enabling DMZ for that computer, I was able to open up port 80 that way. –  Jcmoney1010 Jul 16 '13 at 0:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.