Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OK, here is my setup

-VMWare Fusion 5 with NAT...On the NAT network I have a DNS server (running W12).

I have added an entry for that server on my Mac's /etc/resolv.conf (and the domain too), but cannot resolve directly. I tried to change the order of DNS servers, still no luck.

Here is a snippet of how it fails:

northfarthing:~ aweber$ host mordor mordor.MIDDLEEARTH.TEST has address 192.168.46.100 northfarthing:~ aweber$ ping mordor ping: cannot resolve mordor: Unknown host northfarthing:~ aweber$ nslookup

server 192.168.46.100 Default server: 192.168.46.100 Address: 192.168.46.100#53 mordor Server: 192.168.46.100 Address: 192.168.46.100#53

Name: mordor.MIDDLEEARTH.TEST Address: 192.168.46.100

NorthFarthing is my Mac (it is not in DNS), mordor is my DNS server

so using host command on terminal works, but ping cannot resolve the name !! weird !!

And, even changing the order in resolv.conf did not work, but selecting the proper server in nslookup worked. So it does not seem to be a VMWare / NAT issue. I am a bit puzzled here

Thanks !

share
add comment

This site is currently not accepting new answers.

Browse other questions tagged .