Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I swapped HDDs via system image, and I'd been running ok with the old HDD unplugged. Win7 and Win8 installed, Win7 my main os forever, Win 8 installed on my new HDD after the swap.

Today I decided to get my old HDD back on and formatted. First I plugged the old HDD in and tried booting back up. It wouldn't boot at first, so I ran system repair, which didn't work at first either, until I swapped SATA cables and ran it again. Then Win7 booted and looked normal, although I didn't test it thoroughly my desktop was as I had left it. Although my boot options were Win7, Win8 (recovered), Win7 (recovered), which seemed slightly odd.

The odd thing though was that MSE wasn't running real time protection, and it wouldn't start, then when I went to format C (the old drive) it warned me, saying c was in use, which should've given me pause since I didn't open anything and had booted from my new drive. So I restarted and formatted it with disk part from my recovery disc.

And things became screwy. It now says my copy of Win7 isn't genuine, which isn't totally shocking, but I can't do anything at all--in Vista at least, it had basic functionality and a place to put in my product key. And it won't even let me login to non admin accts. And on my main acct. it says preparing desktop every time I login, before delivering me to the non-functioning desktop that only says "this copy of Windows is not genuine".

I've tried unplugging the old hdd, no luck, tried swapping which cable my new HDD is plugged into, no luck. The only silver lining is my copy of Win 8 with lost product key is working, and all my old files are still on the drive- just Win7 doesn't want to work.

I should also mention that system repair disk boot repair doesn't work- it just says version mismatch, I presume in reference to the missing Win7 install. It still lists Win7 on the boot menu.

share|improve this question
    
Just reactive your license... –  Ramhound Jul 16 '13 at 1:40
    
How would I do that? I can literally do nothing when I login on my"invalid“ Win7, even safe mode, except control alt delete to log off, and I see no activate option from my install/recovery disc. –  j.i.h. Jul 16 '13 at 1:52

1 Answer 1

up vote 0 down vote accepted

The solution turned out to be fairly straightforward. Thanks to a post on sevenforums

crodgers wrote:

In short:

  • boot to safe mode with command prompt
  • (attempt to) log in
  • ctl-alt-del
  • choose task manager
  • applications tab, new task
  • check to run as administrator
  • browse (it brings up windows explorer)
  • note the new drive letters and remember what they used to be
  • cancel out of windows explorer , type regedit in the new task box
  • go to HKey_Local_Machine
  • go to System
  • go to MountedDevices
  • rename the Names with the drive letters (\DosDevices\C to be what they used to be. You may need to start by renaming one to a drive that does nto exist just to free up the name.
  • exit out and reboot
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.