Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My institution uses a cisco ssl vpn which I connect to with anyconnect secure mobility client.

I have a server running sshd and r-studio server at the institution, which is only accessible from on-site or VPN ip addresses.

When logged into the vpn with anyconnect from home, I can ssh to the server, but cannot access the r-studio server through my web browser with port 8787 (default rstudio www-port). I have also tried changing the r-studio www-port to 80 with no luck.

Pretty much anything through a browser isn't tunneled through the VPN.

How can I access this and other services through my institution's vpn from my web browser?

Thanks!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

This will vary depending on the network and route settings for your organization. Cisco and other VPNs advertise certain routes to connected clients. It sounds like the DNS to resolve the r-studio server, or the r-studio server itself, is not on a route advertised by the VPN. When troubleshooting with your system administration team, they may ask you to try to connect by the IP address of the server (do you know this?) or ping the server, or telnet to the server and port combination. In the end, this sounds like a configuration problem that you will need organizational support to resolve.

Make sure that you only have one connection active, and are not on any home networks with a similar IP address to the r-studio one. If an advertised route conflicts with a route to your home router, there might be a conflict. Try changing the IP range offered by your home router, and check for any other virtual networks, such as from virtual machines.

EDIT: I also notice you drew particular attention to the browser. "Anything through a browser" isn't working. By the same principles, check your browser's Proxy setting. If you have previously been accessing a proxy, that proxy may no longer be on an available network. If this is the case, you'll have to change your browser settings not to use a proxy when connected to the VPN.

And remember: Don't Panic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.