Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is a wired work LAN network with 4 computers on it. The workgroup name is the same on all of them. Three of the computers are Windows XP computers and one is a Windows 7 computer. Not all of the computers can see each other. Here is what the different computers can see:

  1. XP 1 can see XP 2 and XP 3 but not W7
  2. XP 2 can see XP 3 and W7 but not XP 1
  3. XP 3 can see XP 2 and W7 but not XP 1
  4. W7 can see XP 2 and XP 3 but not XP 1

Pings go through both ways from XP 1 and W7 to each other.

On W7, network discovery is on, file and printer sharing is on, and public folder sharing is on.

How can I get XP 1 to be seen by all of the computers and to see W7?

share|improve this question
    
What do you mean by "see"? How are you trying/expecting to "see" them? if you explorer to \\machineName can you contact them and see the shares? If you're just trying to "browse" for them in Network Neighborhood/My Network Places or alike, do you have NetBIOS turned on, on all of the machines? –  Ƭᴇcʜιᴇ007 Jul 16 '13 at 17:25
    
I can contact them and see the shares if I explorer to \\machineName, but I just enabled NetBIOS in both XP 1 and W7 and they still cannot see each other when looking at the network devices/My Network Places. –  kuwaly Jul 16 '13 at 18:21
    
If you're using NetBIOS to display them then check into my answer. Having multiple "Master Browsers" in a Workgroup, or even just multiple computers TRYING to be Master, can cause the problems you're seeing. –  Ƭᴇcʜιᴇ007 Jul 16 '13 at 18:23

1 Answer 1

Ensure that the machines aren't fighting to be "Master Browser" (check Windows' Event Logs for events mentioning Browser elections).

If there are events about machines trying to become the master, but being rejected, that could be your trouble.

Pick a machine (generally the 'strongest') to be the Master Browser, and then on all the others disable the "Computer Browser" service.

share|improve this answer
    
How do I set a computer to be the Master Browser and then disable "Computer Browser" on the rest of the computers? –  kuwaly Jul 16 '13 at 18:23
    
The Master Browser is elected (by the computers on the network) from computers that have the Computer Browser service running; if there's only one with that service running, it should be elected Master by the others. To disable computer Browser service: Run services.msc and then find and disable the Computer Browser service, or head to the Services section of Computer Management and do the same, or type SC config Browser start=disabled. –  Ƭᴇcʜιᴇ007 Jul 16 '13 at 18:30
    
I did this and it didn't solve the problem. When I use net view in command prompt to search for the computers on the network (using the W7 computer), all that shows up is XP 2. When it is done using XP 1, it says "NET is not recognized as an internal or external command, operable program, or batch file." This isn't new--it was happening before I changed the Master Browser. –  kuwaly Jul 16 '13 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.