Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The wifi interface won't turn on when i press "Activate wifi" from the preferences neither from the status bar. I tried restarting the mac,and reset the pram. The ethernet works fine and this is the result of ifconfig in the terminal:

ether a8:20:66:37:81:d9 
inet6 fe80::aa20:66ff:fe37:81d9%en0 prefixlen 64 scopeid 0x4 
inet netmask 0xffffff00 broadcast
media: autoselect (100baseTX <full-duplex,flow-control>)
status: active

ether 5c:96:9d:89:fe:09 
media: autoselect (<unknown type>)
status: inactive

Is there anything I can try before initialize OSX?

share|improve this question
The console (/Applications/Utilities/ should say something when you try to “Activate Wifi”. Try looking in “all messages”, system.log, kernel.log. – Nicolas Jul 16 '13 at 16:46
up vote 1 down vote accepted

Go to System Preferences > Network, select the WiFi interface, click the action button (gear icon in the lower left), and select "Make Service Active."

This answer is based on the ifconfig reporting that en1 status is "inactive."


For troubleshooting purposes, try the following:

1) Remove the WiFi interface from the list of available network interfaces in System Preferences, restart the computer, then try to re-add it. If it's not listed as available...

2) Login as another user and see if the issue persists. If it does not persist in the other user, the issue is likely related to a preference in the user library of the first user. Instructions on how to find the user library can be found here.

The only item inside the user folder that MIGHT deal with network interfaces would be in "Preferences," but in my experience I haven't found anything in there that would deal with the network interfaces. If the issue DOES persist in another user...

3) Navigate to /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and copy it to your Desktop. Then move the original to the trash (you'll have to authenticate as an admin). Restart your computer and see if WiFi is detected.

NOTE: The /Library is sometimes called 'root' or 'local' library and is found at the root of your drive alongside "Applications", "System", and "Users."

4) If you have Mac OS X installed on an external drive, you can boot into Startup Manager and boot from that drive. If WiFi is still not detected in that external OS, it's likely a hardware issue. If it IS detected in the external OS but not detected in your internal (and the previous three steps did not resolve it), I'd reinstall Mac OS X.

share|improve this answer
The service was actually active.. I then deactivated and reactivated it but nothing has changed. – Lolloz89 Jul 17 '13 at 12:21
Thank you thankyour, I did all the steps above but the problem persists.. I'll bring the mac to the Apple Store on monday.. – Lolloz89 Jul 18 '13 at 7:14

sh-3.2# ifconfig en0 up

If you did a restart and wifi still not working, type command above to turn the connection back on.

*restarts will reset your mac address if you changed it, but won't turn the connection back on if it was turned off.

*If you replace the (up) with (down) it will turn it off again.

*This applies to en0, en1, en3. In my case it was en0.

*I used this in Yosemite 10.10.1 --worth a try if your struggling--

thats it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.