Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been messing with an old Brother WP-2200 and I've hit a bit of a snag. I was hoping I would be able to make images out of the floppies I typed on it using dd under Linux. Unfortunately that hasn't worked. I've tried dd on about six different computers and they all have produced something similar to the following:

petrusd987@Peters-Gaming-Ubuntu:/tmp$ sudo dd if=/dev/zero of=/dev/sdd bs=1440k count=1
dd: writing to ‘/dev/sdd’: No space left on device
1+0 records in
0+0 records out
0 bytes (0 B) copied, 0.000530324 s, 0.0 kB/s

This also produces the same result when done in reverse. I don't understand why this is happening because I know for a fact that the floppy I used in the device was working perfectly under dd before the WP-2200 formatted it. I do know that these machines use a proprietary file system not recognized by computers if that helps anyone. I didn't think that mattered though because DD works at the binary level. Any help in fixing this would be greatly appreciated.


Update:

I didn't really word this post very well so I'd like to try to make it a bit clearer. The disk was not write protected when I was working with it. Below is three of the commands I have tried and the output I am given:

I would like to point out that the floppy has changed to sdb when I rebooted because I have removed my external hard drive and flash drive.


**Copying: Writable**

sudo dd if=/dev/sdb of=/tmp/flp.img
0+0 records in
0+0 records out
0 bytes (0 B) copied, 0.000530151 s, 0.0 kB/s


**Erasing: Read-only**

petrusd987@Peters-Gaming-Ubuntu:/tmp$ sudo dd if=/dev/zero of=/dev/sdb
[sudo] password for petrusd987: 
dd: opening ‘/dev/sdb’: Read-only file system

**Erasing: Writable**

petrusd987@Peters-Gaming-Ubuntu:/tmp$ sudo dd if=/dev/zero of=/dev/sdb
dd: writing to ‘/dev/sdb’: No space left on device
1+0 records in
0+0 records out
0 bytes (0 B) copied, 0.00111174 s, 0.0 kB/s

This is my problem. I'm assuming that it is attempting to append to the floppy. This is not what I want. I want it to start at the beginning of the floppy and write the zeros. How do I do this?

share|improve this question
    
Are we talking about such a machine, i.e. a kind of typewriter? s3.amazonaws.com/kpsurplus_images/… –  mpy Jul 17 '13 at 9:53
    
So you run the same command twice and get the different outputs shown? Have you checked the write protect switch I mentioned in my answer? Could you post the output of df -h and mount | grep sdb please? –  terdon Jul 17 '13 at 13:08
add comment

2 Answers 2

up vote 3 down vote accepted

The command you posted above will write 1440k of 0s into your floppy, it will not copy anything from it. Since the disk is full however, dd cannot write to the device and the command fails. Lucky you...

If you want to take an image of the data on the floppy do this:

dd if=/dev/sdd of=floppy.img 

That will create a image file of your floppy called floppy.img. dd is a dangerous command, I recommend you read through man dd carefully before attempting to use it.


Another possible problem (assuming you run the dd correctly and not the way you have shown in your answer) is that the floppy is write protected. 31/2 inch floppies had a little switch that allowed you to toggle write protection (image from here):

enter image description here

Make sure that is in the correct position to allow writing. Normally, if a drive is mounted read only, you get a permission denied or similar error. I don't remember the error you got if attempting to write to a write protected floppy.

share|improve this answer
    
I'm not sure about that (too long since I fiddled with FDDs), but wouldn't the error be the same if the FDD is write-protected? (So yes, lucky OP!) Otherwise dd would have written zeros starting from the beginning and hence more than 0 records? –  mpy Jul 16 '13 at 17:29
    
I don't know the WP-2200, but I could imagine that the floppy is formatted to some uncommon format, so that bs=1440k will be either too much or too less. To make a complete image, I usually use only dd if=/dev/sdd of=floppy.img without bs. [OT: The only case I ever had where I really needed the bs parameter is when reading/writen from/to a tape drive.] –  mpy Jul 16 '13 at 17:37
    
@mpy that was my first thought too but since the dd command is completely wrong, I doubt that is the problem. IN any case, I updated my answer to include the write toggle switch. I also removed the bs, good point. –  terdon Jul 16 '13 at 17:38
    
Thank you all for your help. –  Petrusd987 Jul 16 '13 at 21:05
    
@Petrusd987 you're very welcome. If this answers your question, please remember to accept it. –  terdon Jul 16 '13 at 23:05
show 2 more comments

I do know that these machines use a proprietary file system not recognized by computers if that helps anyone. I didn't think that mattered though because DD works at the binary level.

You are right, dd doesn't bother about filesystems or what so ever. That is not the problem. I'm pretty sure now that the todays 3.5" floppy drives are the problem.

Remember, even if you use a 1.44MB (i.e. a HD) medium, that is saying nothing about the logical structure which is generated upon formatting. I mean, how much bytes per sector, how much sectors per track and how much tracks per medium are written.

Nowadays (ok, in the last decade) a 1.44MB floppy uses 512 bytes per sector, 18 sectors per track, 80 tracks per side and two sides, for a total of 1,474,560 bytes per disk [1][2]

If your Brother WP-2200 uses anything different from that (or the other formats used by PC drives; Microsoft's KB has a nice overview [3] or again a link to Wikipedia [4]), your dd command is doomed not to work, just because the floppy drive isn't able to read the bytes-secs-tracks geometry of the WP-2200 formatted disk. Usually in that case you hear a strange sound from your floppy drive, trying to find the tracks and sweeping back and forth a few times.

This forum thread supports my assumption.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.