Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am keep failing in the installation process I have tried.

I have started process as follows.

yum install gcc dbus-glib-devel* lua-devel* libcddb
wget http://download.videolan.org/pub/videolan/vlc/2.0.7/vlc-2.0.7.tar.xz
tar -xf vlc-2.0.7.tar.xz && cd vlc-2.0.7
./configure

in the configure I am getting the error as follows

configure: WARNING: No package 'libcddb' found: CDDB access disabled.
checking for Linux DVB version 5... yes
checking for DVBPSI... no
checking gme/gme.h usability... no
checking gme/gme.h presence... no
checking for gme/gme.h... no
checking for SID... no
configure: WARNING: No package 'libsidplay2' found (required for sid).
checking for OGG... no
configure: WARNING: Library ogg >= 1.0 needed for ogg was not found
checking for MUX_OGG... no
configure: WARNING: Library ogg >= 1.0 needed for mux_ogg was not found
checking for SHOUT... no
configure: WARNING: Library shout >= 2.1 needed for shout was not found
checking ebml/EbmlVersion.h usability... no
checking ebml/EbmlVersion.h presence... no
checking for ebml/EbmlVersion.h... no
checking for LIBMODPLUG... no
configure: WARNING: No package 'libmodplug' found
No package 'libmodplug' found.
checking mpc/mpcdec.h usability... no
checking mpc/mpcdec.h presence... no
checking for mpc/mpcdec.h... no
checking mpcdec/mpcdec.h usability... no
checking mpcdec/mpcdec.h presence... no
checking for mpcdec/mpcdec.h... no
checking for libcrystalhd/libcrystalhd_if.h... no
checking mad.h usability... no
checking mad.h presence... no
checking for mad.h... no
configure: error: Could not find libmad on your system: you may get it from http://www.underbit.com/products/mad/. Alternatively you can use --disable-mad to disable the mad plugin.
[root@localhost vlc-2.0.7]# 

So I went to libmad http location and downloaded it and while doing make it gave me the errors.There are no errors at ./configure with libmad but make not going through.

[root@localhost libmad-0.15.0b]# make
(sed -e '1s|.*|/*|' -e '1b' -e '$s|.*| */|' -e '$b'  \
        -e 's/^.*/ *&/' ./COPYRIGHT; echo;  \
    echo "# ifdef __cplusplus";  \
    echo 'extern "C" {';  \
    echo "# endif"; echo;  \
    if [ ".-DFPM_INTEL" != "." ]; then  \
        echo ".-DFPM_INTEL" | sed -e 's|^\.-D|# define |'; echo;  \
    fi;  \
    sed -ne 's/^# *define  *\(HAVE_.*_ASM\).*/# define \1/p'  \
        config.h; echo;  \
    sed -ne 's/^# *define  *OPT_\(SPEED\|ACCURACY\).*/# define OPT_\1/p'  \
        config.h; echo;  \
    sed -ne 's/^# *define  *\(SIZEOF_.*\)/# define \1/p'  \
        config.h; echo;  \
    for header in version.h fixed.h bit.h timer.h stream.h frame.h synth.h decoder.h; do  \
        echo;  \
        sed -n -f ./mad.h.sed ./$header;  \
    done; echo;  \
    echo "# ifdef __cplusplus";  \
    echo '}';  \
    echo "# endif") >mad.h
make  all-recursive
make[1]: Entering directory `/home/raja/Downloads/libmad-0.15.0b'
make[2]: Entering directory `/home/raja/Downloads/libmad-0.15.0b'
if /bin/sh ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. -DFPM_INTEL -DASO_ZEROCHECK    -Wall -march=i486 -g -O -fforce-mem -fforce-addr -fthread-jumps -fcse-follow-jumps -fcse-skip-blocks -fexpensive-optimizations -fregmove -fschedule-insns2 -fstrength-reduce -MT version.lo -MD -MP -MF ".deps/version.Tpo" \
      -c -o version.lo `test -f 'version.c' || echo './'`version.c; \
    then mv -f ".deps/version.Tpo" ".deps/version.Plo"; \
    else rm -f ".deps/version.Tpo"; exit 1; \
    fi
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I. -DFPM_INTEL -DASO_ZEROCHECK -Wall -march=i486 -g -O -fforce-mem -fforce-addr -fthread-jumps -fcse-follow-jumps -fcse-skip-blocks -fexpensive-optimizations -fregmove -fschedule-insns2 -fstrength-reduce -MT version.lo -MD -MP -MF .deps/version.Tpo -c version.c  -fPIC -DPIC -o .libs/version.lo
cc1: error: unrecognized command line option "-fforce-mem"
make[2]: *** [version.lo] Error 1
make[2]: Leaving directory `/home/raja/Downloads/libmad-0.15.0b'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/raja/Downloads/libmad-0.15.0b'
make: *** [all] Error 2

how can i resolve the issue and install VLC in my Centos ?

I am using CentOS 6.4 . Thank you.

share|improve this question
up vote 6 down vote accepted

Solution To install VLC on CentOS 6.4

Open the terminal and follow few steps

cd /etc/yum.repos.d/

wget http://pkgrepo.linuxtech.net/el6/release/linuxtech.repo

yum install vlc

Enjoy open source environment.

share|improve this answer
    
that has installed 2.0.5, but i want 2.0.7. – Raja Jul 17 '13 at 12:36
    
Download the latest atrpms-repo rpm from dl.atrpms.net/el6-i386/atrpms/stable Install atrpms-repo rpm: # rpm -Uvh atrpms-repo*rpm Install vlc rpm package: # yum install vlc – Shailesh Jul 17 '13 at 13:10
    
are you use 64bit OS or 32bit OS ? – Shailesh Jul 17 '13 at 13:23
    
I am using 32-Bit OS. – Raja Jul 18 '13 at 11:18
    
#Download the latest atrpms-repo rpm from # wget dl.atrpms.net/el6-i386/atrpms/stable/… #Install atrpms-repo rpm: # rpm -ivh atrpms-repo*rpm #Install vlc rpm package: # yum install vlc – Shailesh Jul 18 '13 at 12:33

You can use RPM Fusion EL6 on your system. Got to http://rpmfusion.org/Configuration and install the repo in your system and then installed via Yum.

share|improve this answer
    
Ok I will try and let you know. Thank you. – Raja Jul 18 '13 at 11:19
    
Transaction Check Error: file /usr/lib/libpostproc.so.52 conflicts between attempted installs of ffmpeg-libs_1.1-1.1.5-2.el6.i686 and ffmpeg-libs-0.10.7-1.el6.i686 file /usr/lib/libswresample.so.0 conflicts between attempted installs of ffmpeg-libs_1.1-1.1.5-2.el6.i686 and ffmpeg-libs-0.10.7-1.el6.i686 file /usr/lib/libswscale.so.2 conflicts between attempted installs of ffmpeg-libs_1.1-1.1.5-2.el6.i686 and ffmpeg-libs-0.10.7-1.el6.i686 – Raja Jul 18 '13 at 13:07
    
Try to remove ffmpeg and then install it. – Paulo Fidalgo Jul 18 '13 at 13:15
    
pastebin.centos.org/3313 – Raja Jul 18 '13 at 14:16

Step by Step installation of VLC 2.0 on CentOS 6.4 can be successfully done by implementing the instructions.

share|improve this answer
2  
Link-only answers are a no-no due to possible future link-rot. Please include pertinent information directly in your answers, and cite the site as a source. – Ƭᴇcʜιᴇ007 Oct 27 '14 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .