Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using the full-screen console mode in Mac OS X accessed by entering the username '>console', I would like to use a different keyboard layout and would like support for colors.

The terminal seems to be set to vt100 while Terminal windows use xterm-color, but I can't figure out how to change that (if that is even the way to enable color).

I also grep'd for loadkeys under /etc to try to determine where the keyboard layout was being loaded, but came up with nothing.

share|improve this question
    
Earn a bounty for answering the keyboard layout part of this question. –  Evan Krall Sep 19 '11 at 1:04

3 Answers 3

up vote 4 down vote accepted

For your keyboard layout you might find you'd have to manually remap keys; sadly I'm only familiar with doing this for an X11 manager. Perhaps that notion will set you in the right direction.

For your coloring needs, type this in:

export TERM=xterm-color

It will switch your term to xterm-color like Terminal, then try ls -G (color mode for ls).

share|improve this answer
    
Setting the TERM worked and setting it in my .bash_profile made it permanent. I tried kbdcontrol to remap the keys but it doesn't seem to be available. –  dma Oct 29 '09 at 4:21

@Evan, does this solve your bounty?

share|improve this answer
    
Unfortunately, no. It does change the keyboard layout for the login window, but the >console terminal remains in qwerty. –  Evan Krall Sep 25 '11 at 4:15
    
damn. well it was worth a shot. –  peelman Sep 25 '11 at 19:39

From How to change the language displayed in the login window :

The text of the login window will be displayed in the language that was selected when Mac OS X was installed, or the language selected the first time Mac OS X was started on a new Mac. Learn how you can change the language used for the login window. Products Affected

There are two ways to change the language of the login window:

  • Reinstall Mac OS X and select the desired language during installation, or
  • Use the steps below depending on your version of Mac OS X.

Mac OS X v10.4 or later

  1. Login as a user who has an administrator account.
  2. Open Terminal (in /Applications/Utilities/).
  3. Type or paste this command in Terminal:
    sudo languagesetup
    and press Return.
  4. When prompted for a password, enter your account password and press Return again. If your user has no password (a blank password) and you are using Mac OS X 10.5 or later, see Mac OS X 10.5 or later: sudo command requires a non-blank admin password.
  5. A list of available languages will be displayed.
    Type the number that appears next to the language you want to use, then press Return.
  6. Quit Terminal.
share|improve this answer
    
This may work for switching languages but unfortunately doesn't have an option for keyboard layouts like Dvorak. –  Evan Krall Sep 25 '11 at 4:16
    
Dvorak was not specified in the question, but it is strange that you don't have it. Does it exist in System Preferences ? –  harrymc Sep 25 '11 at 7:16
    
It's possible to change it in System Prefs, but nothing seems to affect the >console keyboard layout. –  Evan Krall Sep 25 '11 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.