Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Suddenly and without notice, VirtualBox application doesn't start.

First, it just didn't do anything. Not even an error message. I looked in the system log (/var/log/system.log) and I found these two messages repeated every time I tried starting VirtualBox:

[0x0-0xbb0bb].org.virtualbox.app.VirtualBox[4224]: VirtualBox: supR3HardenedVerifyDir: Cannot trust the directory "/Applications/VirtualBox.app/Contents/
MacOS": group and/or other writable (st_mode=040777)
com.apple.launchd.peruser.501[237] ([0x0-0xbb0bb].org.virtualbox.app.VirtualBox[4224]): Exited with code: 1

I did some research and found similar problems, most of them indicating problems with permissions. So I found that in order to fix it, I should change the permissions as follows:

sudo chmod 755 /Applications/VirtualBox.app/Contents/MacOS
sudo chmod 755 /Applications/VirtualBox.app/Contents/MacOS/components

After that, when trying to start the application I get a pop-up window saying:

Effective UID is not root (euid=501 egid=20 uid=501 gid=20) (rc=-20)

Please try reinstalling VirtualBox.

I would like to avoid that suggestion, as I have many important VMs and I don't want to lose them.

Then, is there any way to fix this without reinstalling. I haven't found any other good info about this that could solve the problem.

If there was no other option than reinstalling, is there anyway to backup the VMs? Digging into VirtualBox directory I haven't found anything sounding like a VM package/file containing each VM.

Regards

share|improve this question
2  
Reinstalling the VirtualBox application does not remove your virtual machines, so why not try that? They are not contained in the .app file. –  slhck Jul 17 '13 at 15:11
    
D'oh! I didn't know that. Where are they contained by default? –  ferguior Jul 18 '13 at 14:33
    
@ferguior I think it's in your user profile. –  Jeffrey Lin Jul 18 '13 at 19:27

2 Answers 2

up vote 1 down vote accepted

All your VirtualBox VMs and the application's settings are not stored in the actual .app file. You can try reinstalling it by just running the installer again. This is also how you would update VirtualBox to a newer version.

Your original VMs and settings are stored in ~/VirtualBox VMs, ~/Library/VirtualBox and ~/Library/Preferences, respectively. You can of course make a backup of those if they are really important to you, and if you haven't yet it's really a good time to set up Time Machine.

share|improve this answer
    
Thanks. Re-installing solved the problem and I kept my VMs. Although, they were under /Users/<username>/VirtualBox VMs. –  ferguior Jul 21 '13 at 21:14
    
Glad it worked. I must have been using an older version that keeps the files somewhere else. –  slhck Jul 22 '13 at 6:37
    
This issue is coming up for me when I log into my Mac as a second user, frequently. I'd like to see an actual fix that avoids continual re-installs, since these destroy permissions on Windows virtual boxes that I use as a developer for testing apps and websites in IE. Doesn't anyone have a fix? –  Deborah Speece Mar 28 at 20:27

For me, the accepted answer was an unattractive workaround, since re-installing Virtual Box destroys authorization for the Windows Virtual Boxes that I spent a day downloading, installing and setting up for testing apps and websites on different versions of heinous IE.

The core issue is that permissions have become messed up, and Virtual Box is picky about them.

Here is a solution for those who, like me, would rather not spend another wasted day on getting IE testing up and running with Windows in Virtual Box.

  • in Finder, use "Go" to go to this folder: /Applications/VirtualBox.app/Contents/

  • Click on Folder “MacOS”

  • Get info

  • Unlock the lock at the bottom right of the window

  • Make sure only system can read and write

  • Click the gear to apply to all enclosed items

  • close this window

Now Terminal can open Virtual Box:

sudo /Applications/VirtualBox.app/Contents/MacOS/VirtualBox

Virtual Box should launch.

*However, whenever you want VirtualBox to launch, you must use the sudo line above in Terminal, clicking the app still throws the error. *

I'll post an edit if I can get past that. At least pasting that line in Terminal doesn't take a day. Good luck everybody!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.