Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a USB flash drive with a hidden encrypted partition on it. I'd like to reuse it, but so far I have been unsuccessful in wiping it.

It is an SanDisk Cruzer 8GB with what I assume was with the U3 software that originally came along with it.

Viewing it in Windows 7's Disk Management tool only reveals a 64MB RAW partition that I can't delete or format.

I attempted to use the diskpart command line tool, but was unable to format or delete the partition. Since I'm unfamiliar with the tool, I just might not be using the correct sequence of commands:

list disk
select disk 1
list partition
select partiton=1
delete partition override

(The USB flash drive is listed as disk 1, and within it, lists the 64MB partition as partition 1 with no other partitions.)

This sequence results in the error message:"There are no partitions selected. Please select a partition and try again."

What would be the correct way to wipe and reuse this USB flash drive?

share|improve this question

For your specific case, SanDisk has a free U3 Removal Tool download available on their website.

share|improve this answer
    
The download link is dead. It just redirects to their main KB site. – Force Flow Jul 17 '13 at 20:46
    
@ForceFlow I just edited the post - try the updated link. – nhinkle Jul 17 '13 at 20:47
    
The link worked, but the tool did not. When I run it, all it says is "please insert a U3 smart drive". So either I was mistaken about U3, or I destroyed the 64MB partition well enough so the tool doesn't work. – Force Flow Jul 17 '13 at 20:50
    
@ForceFlow can you find a copy of the U3 Restore tool they talk about, try to restore the partition, and then try to remove it? – nhinkle Jul 17 '13 at 20:59
    
Before I went ahead with that suggestion, I ejected the drive to check the info written on it, then put it back in, and suddenly I had access to the ~8GB partition. I ran the U3 removal tool, but it didn't see the drive, so I just formatted the ~8GB partition. Very strange. – Force Flow Jul 17 '13 at 21:09

Instead of trying to delete the partition, you could just wipe the drive's partition table:

list disk
select disk 1
clean

From there, you should be able to partition it using Disk Management like you would a normal disk.

share|improve this answer
    
Nope, that still didn't do it. The 64MB RAW partition is still there, and I can't see any additional storage space. – Force Flow Jul 17 '13 at 20:45

I'm a little late to this discussion, granted. But every time I saw that phantom U3 CD drive, my jaws tightened all the more. Anyway, tapped-out, you were almost right. In order to use "clean" and get it to work, you need to add the switch "all, as in "clean all" (in Win 7 64).

The clean solution I just described presumes you are familiar with Diskpart and the need to run CMD in a heightened state aka run as an admin. If you are - then you're golden. I haven't seen those annoying cd drives in a long time and I have access to the entire USB the I paid for.

UMRK

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .