Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to be having a problem, for a few weeks I have been hearing the random sound of connecting and disconnecting of a USB device. nothing is shown in my tool bar and in device manager I can not see anything at all. I have no power saving options, I did a system restore which didn't fix the problem. When the sound is made my mouse and keyboard and anything else that is USB connected works fine. I have disabled my wireless card on my PC as I don't use it and I still now and then hear the wonderful sound of something being disconnected. Now I have no idea what so ever on what it could be.

So I am asking here if anyone has had this problem and what they did to resolve it, or if anyone can give me a hand on removing this terrible plague :( Also my computer is running Windows 7

P.S. At the moment I am watching a video on twitch and it is playing the sound alot...

share|improve this question
2  
Maybe this is your issue too. Or this? – nixda Jul 17 '13 at 20:03
    
yea something like that – Canvas Jul 17 '13 at 21:06
    
There's someone with the same problem, here's the link: superuser.com/questions/125377/… – Joris Mar 4 '14 at 16:50

Here's what eventually solved my problem. I downloaded USBDeview which lists the entire history of every device you connected via usb.

After viewing the entire history of every device ever connected via usb, I noticed several were from years back by looking at the last plug/unplug date. I progressively starting selecting devices from 2 years ago and choosing uninstall selected device. Repeat again for 1 years ago, etc. I eventually did this for all devices except for those connected in the past month.

This solved my issue. I can't explain why it did other than the history of old devices was gone so windows had nothing to probe or try to reconnect. Its possible that as I disconnected or move devices around, something in windows was probing an old device and in the process, was disconnecting the device currently connected to that USB port.

Hope this works for others.

share|improve this answer

For me it wasn't a USB device at all. Turns out it was my bluetooth adaptor. Just turned that off and everything was fine!

share|improve this answer
    
Okay, admittedly turning off the Bluetooth is not a "fix". But in my case I wasn't using Bluetooth at all so that was as far as I was willing to go to handle this issue. I think my answer has value in that the root of the issue could be non-USB related. – gillytech Nov 16 '15 at 23:52

protected by bwDraco Dec 25 '15 at 21:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.