Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am successfully able to install Fedora 17 (32 bit) along with Windows 8 on my system. But when I restart the system, the GRUB 2 menu doesn't show the windows 8.

To troubleshoot the problem, I tried installing a third OS (Backtrack 5) on the system. And this time when I restarted the system, the GRUB menu listed all the three OS in the machine including Windows 8.

So, I figured out that there is a some problem with the GRUB 2. I am not sure though because for one of my friend(who by the way is using a 64 bit machine), the dual boot worked absolutely fine.

Anybody else who had experienced the same problem before or any idea what could be the reason behind this?

share|improve this question
It was probably a one-time thing where the Grub menu didn't get updated properly. You could have tried repairing Grub instead of installing yet another OS. – Karan Jul 17 '13 at 21:47
I don't think so. I had the same problem with Fedora 18 and it was working fine on a 64 bit machine. – Rahil Arora Jul 17 '13 at 22:28
up vote 0 down vote accepted

I guess there was some problem with the GRUB 2 in the 32 bit versions of Fedora 17 and 18. I tried the same with Fedora 19 and everything was working just fine. My GRUB menu is now showing all the operating systems on my Hard drive.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .