Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have problem with my php mail(). I have check smtp server is enabled. php.ini is as follows:

[mail function]

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_parameters =

So I read some offline document saying to use postfix to solve it. But I am new to Postfix. I have putty. I tried http://www.servermom.com/easy-way-to-install-postfix-on-ubuntu-server/197/ but I have problem even at step 1 (apt-get error). Please help me..

share|improve this question

migrated from stackoverflow.com Jul 17 '13 at 23:53

This question came from our site for professional and enthusiast programmers.

    
Have you managed to successfully login to your server first via the putty ssh client? If you have, and you are getting errors from apt-get, try prefixing the command with sudo apt-get... Report back with the exact steps or commands that you tried. –  user237794 Jul 17 '13 at 5:15
    
Hi. I tried sudo. I get this error: sudo: apt-get: command not found –  user2041851 Jul 17 '13 at 5:38
    
Ok, so I guess sudo isn't installed by default in your system. You are running as root though I hope? What is the initial error you got from apt-get that you mentioned in your problem description? Can you take a screenshot and upload it on imgur.com ? –  user237794 Jul 17 '13 at 5:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.