Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Mac has Emacs v22 and it only splits horizontally when I type ^x-2.

My Linux system has Emacs v24 and it splits vertically when Emacs thinks that's a better choice. The problem is, I don't want it to split that way. How do I prevent emacs from splitting vertically?

share|improve this question
1  
Odd as the manual shows C-x 2 (split-window-below). Look in the .emacs settings file or the customization interface and check if this has been re-assigned to split-window-right. –  Brian Jul 18 '13 at 1:58
    
Type C-h k C-x 2. Is the key properly set to split-window-below? –  Brandon Invergo Jul 18 '13 at 9:58
    
The problem seems to show up with grep, compile, goto next error, and gdb commands. –  vy32 Jul 19 '13 at 2:33
add comment

2 Answers

up vote 1 down vote accepted

See the Emacs manual, node Window Choice. In particular, see user options split-height-threshold and split-width-threshold.

share|improve this answer
add comment

For splitting horizontally use C-x 3. You can find more options here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.